Bug 737437 - gnome-screensaver becomes very often inoperable (Segmentation fault?)
gnome-screensaver becomes very often inoperable (Segmentation fault?)
Status: CLOSED DUPLICATE of bug 736987
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-12 01:31 EDT by Joachim Backes
Modified: 2011-09-12 09:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-12 09:30:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2011-09-12 01:31:40 EDT
Description of problem:
having very often the problem that after some time inside a gnome-shell session the screen can't be locked by the gnome-shell user menu or by the ctrl+alt+l key combination.

This seems to be related to a crashing (??) gnome-gnomesceensaver:

after having logged in, gnome-screensaver runs well (as child of
gnome-session), but after some time (can't say how long), no more
screensaver is running. I have to logout and login again for getting a
running screensaver.

Version-Release number of selected component (if applicable):
gnome-screensaver-3.1.91-1.fc16.x86_64

How reproducible:
In each gnome-session after some time

Steps to Reproduce:
1.User menu "lock screen" or ctrl+alt+l
2.
3.
  
Actual results:
nothing happens

Expected results:
screen is locked

Additional info:

strace of a crashing gnome-screensaver (tail of output):
---------------------------------------------------------

poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"\31\0\v\0\4\0\240\1\0\0\0\0\0032\0\0V3|\0\254\0\0\0\4\0\240\1\0\0\0\0"..., 44}, {NULL, 0}, {"", 0}], 3) = 44
read(3, 0x24bc374, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=13, events=POLLIN}, {fd=14, events=POLLIN}, {fd=15, events=POLLIN}, {fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=9, events=POLLIN}, {fd=12, events=POLLIN}, {fd=7, events=POLLIN}, {fd=20, events=POLLIN}, {fd=18, events=POLLIN}], 11, 24446) = 1 ([{fd=3, revents=POLLIN}])
read(3, "#\214\4\5\26\0\0\0\2\0\3\0\3433|\0\n\0\0\0\254\0\0\0=\0`\1\0\0\0\0"..., 4096) = 120
read(3, 0x24bc374, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"\22\0\7\0>\0`\0014\1\0\0\6\0\0\0 3|\0\1\0\0\0\3433|\0\31\0\v\0"..., 72}, {NULL, 0}, {"", 0}], 3) = 72
read(3, 0x24bc374, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=13, events=POLLIN}, {fd=14, events=POLLIN}, {fd=15, events=POLLIN}, {fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=9, events=POLLIN}, {fd=12, events=POLLIN}, {fd=7, events=POLLIN}, {fd=20, events=POLLIN}, {fd=18, events=POLLIN}], 11, 24305) = 1 ([{fd=3, revents=POLLIN}])
read(3, "#\214\6\5\26\0\0\0\2\0\3\00004|\0\v\0\0\0\254\0\0\0=\0`\1\0\0\0\0"..., 4096) = 120
read(3, 0x24bc374, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"\22\0\7\0>\0`\0014\1\0\0\6\0\0\0 3|\0\1\0\0\00004|\0\31\0\v\0"..., 72}, {NULL, 0}, {"", 0}], 3) = 72
read(3, 0x24bc374, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=13, events=POLLIN}, {fd=14, events=POLLIN}, {fd=15, events=POLLIN}, {fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=9, events=POLLIN}, {fd=12, events=POLLIN}, {fd=7, events=POLLIN}, {fd=20, events=POLLIN}, {fd=18, events=POLLIN}], 11, 24228) = 1 ([{fd=3, revents=POLLIN}])
read(3, "#\214\10\5\26\0\0\0\3\0\3\0f4|\0\n\0\0\0\254\0\0\0=\0`\1\0\0\0\0"..., 4096) = 120
read(3, 0x24bc374, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"\31\0\v\0\4\0\240\1\0\0\0\0\3\n\0\0f4|\0\254\0\0\0\4\0\240\1\0\0\0\0"..., 44}, {NULL, 0}, {"", 0}], 3) = 44
read(3, 0x24bc374, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=13, events=POLLIN}, {fd=14, events=POLLIN}, {fd=15, events=POLLIN}, {fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=9, events=POLLIN}, {fd=12, events=POLLIN}, {fd=7, events=POLLIN}, {fd=20, events=POLLIN}, {fd=18, events=POLLIN}], 11, 24174) = 1 ([{fd=3, revents=POLLIN}])
read(3, "#\214\t\5\26\0\0\0\3\0\3\0\2504|\0\v\0\0\0\254\0\0\0=\0`\1\0\0\0\0"..., 4096) = 120
read(3, 0x24bc374, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"\31\0\v\0\4\0\240\1\0\0\0\0\3\v\0\0\2504|\0\254\0\0\0\4\0\240\1\0\0\0\0"..., 44}, {NULL, 0}, {"", 0}], 3) = 44
read(3, 0x24bc374, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=13, events=POLLIN}, {fd=14, events=POLLIN}, {fd=15, events=POLLIN}, {fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=9, events=POLLIN}, {fd=12, events=POLLIN}, {fd=7, events=POLLIN}, {fd=20, events=POLLIN}, {fd=18, events=POLLIN}], 11, 24108) = 1 ([{fd=3, revents=POLLIN}])
read(3, "#\214\n\5\26\0\0\0\2\0\3\0\2455|\0002\0\0\0\254\0\0\0=\0`\1\0\0\0\0"..., 4096) = 120
read(3, 0x24bc374, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"\22\0\7\0>\0`\0014\1\0\0\6\0\0\0 4|\0\1\0\0\0\2455|\0\31\0\v\0"..., 72}, {NULL, 0}, {"", 0}], 3) = 72
read(3, 0x24bc374, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=13, events=POLLIN}, {fd=14, events=POLLIN}, {fd=15, events=POLLIN}, {fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=9, events=POLLIN}, {fd=12, events=POLLIN}, {fd=7, events=POLLIN}, {fd=20, events=POLLIN}, {fd=18, events=POLLIN}], 11, 23855) = 3 ([{fd=13, revents=POLLIN}, {fd=14, revents=POLLIN}, {fd=15, revents=POLLIN}])
write(2, "\n(gnome-screensaver:14891): GLib"..., 115) = 115
write(2, "\n(gnome-screensaver:14891): GLib"..., 116) = 116
write(2, "\n(gnome-screensaver:14891): GLib"..., 99) = 99
write(2, "\n(gnome-screensaver:14891): GLib"..., 123) = 123
write(2, "\n(gnome-screensaver:14891): GLib"..., 141) = 141
--- {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=0x24} (Segmentation fault) -
Comment 1 Matthias Clasen 2011-09-12 09:30:13 EDT

*** This bug has been marked as a duplicate of bug 736987 ***

Note You need to log in before you can comment on or make changes to this bug.