Bug 73745 - traceback: SystemError: vgscan failed
traceback: SystemError: vgscan failed
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-09 18:40 EDT by Mike McLean
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-13 15:28:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ks.cfg from failed install (4.45 KB, text/plain)
2002-09-09 18:41 EDT, Mike McLean
no flags Details
full traceback (68.40 KB, text/plain)
2002-09-09 18:42 EDT, Mike McLean
no flags Details

  None (edit)
Description Mike McLean 2002-09-09 18:40:52 EDT
* -re0906.1

Got this traceback during an automated install test.  There was no lvm in this
install.  The previous install did not have lvm either (although it did have
root on /dev/md0 raid1).  The machine had run an lvm case earlier that day, but
afaict it had gone through about 9 successful installs of the same tree before
it hit this traceback.

Will attach details.

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 694, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 402, in run
    (step, args) = dispatch.currentStep()
  File "/usr/lib/anaconda/dispatch.py", line 251, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/partitioning.py", line 57, in partitionObjectsInitialize
    partitions.setFromDisk(diskset)
  File "/usr/lib/anaconda/partitions.py", line 184, in setFromDisk
    lvm.vgscan()
  File "/usr/lib/anaconda/lvm.py", line 38, in vgscan
    raise SystemError, "vgscan failed"
SystemError: vgscan failed

Local variables in innermost frame:
rc: 11
Comment 1 Mike McLean 2002-09-09 18:41:46 EDT
Created attachment 75605 [details]
ks.cfg from failed install
Comment 2 Mike McLean 2002-09-09 18:42:42 EDT
Created attachment 75606 [details]
full traceback
Comment 3 Mike McLean 2002-09-09 18:43:57 EDT
Is this related to bug#73112 ?
Comment 4 Michael Fulbright 2002-09-16 15:12:34 EDT
Yes.

There are still some cases where vgscan will segfault due to incomplete data
being left on the drives. I have a newer lvm package that ought to fix it.
Comment 5 Michael Fulbright 2002-11-13 15:28:22 EST
lvm tools in current tree should help this problem.
Comment 6 Mike McLean 2002-12-10 12:43:07 EST
Well, haven't hit this in a long time.  Closing.
Comment 7 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.