Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 73750 - netstat -ic is not correct.
netstat -ic is not correct.
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
:
Depends On: 59818 64862
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-09 22:51 EDT by Fuchi Hideshi
Modified: 2015-04-19 20:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-09 22:54:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this patch from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=149576&repeatmerged=yes (754 bytes, patch)
2002-09-09 22:52 EDT, Fuchi Hideshi
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:164 normal SHIPPED_LIVE Updated net-tools package fixes netstat -c output 2003-12-19 00:00:00 EST

  None (edit)
Description Fuchi Hideshi 2002-09-09 22:51:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020615
Debian/1.2.5-1.1

Description of problem:
netstat -ic is not correct, when using the -i and -c options.

It is necessary to initialize int_last in free_interface_list().
and proc_read need no.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run netstat -ic
2.
3.
	

Actual Results:  Kernel Interface table
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR   TX-OK TX-ERR TX-DRP TX-OVR Flg
eth0   1500   0  163176   1726      0      0  217459    197      0      0 BMRU
lo    16436   0   22845      0      0      0   22845      0      0      0 LRU
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR   TX-OK TX-ERR TX-DRP TX-OVR Flg
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR   TX-OK TX-ERR TX-DRP TX-OVR Flg
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR   TX-OK TX-ERR TX-DRP TX-OVR Flg
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR   TX-OK TX-ERR TX-DRP TX-OVR Flg


Expected Results:  Kernel Interface table
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR   TX-OK TX-ERR TX-DRP TX-OVR Flg
eth0   1500   0  163240   1755      0      0  217497    197      0      0 BMRU
lo    16436   0   22853      0      0      0   22853      0      0      0 LRU
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR   TX-OK TX-ERR TX-DRP TX-OVR Flg
eth0   1500   0  163240   1755      0      0  217497    197      0      0 BMRU
lo    16436   0   22853      0      0      0   22853      0      0      0 LRU
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR   TX-OK TX-ERR TX-DRP TX-OVR Flg
eth0   1500   0  163243   1755      0      0  217498    197      0      0 BMRU
lo    16436   0   22853      0      0      0   22853      0      0      0 LRU
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR   TX-OK TX-ERR TX-DRP TX-OVR Flg
eth0   1500   0  163247   1755      0      0  217501    197      0      0 BMRU
lo    16436   0   22853      0      0      0   22853      0      0      0 LRU


Additional info:
Comment 2 Phil Knirsch 2002-10-04 04:36:22 EDT

*** This bug has been marked as a duplicate of 64862 ***
Comment 3 John Flanagan 2003-12-19 09:46:15 EST
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-164.html

Note You need to log in before you can comment on or make changes to this bug.