Bug 73753 - pppd does not support xxx-filter options
pppd does not support xxx-filter options
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-10 02:32 EDT by Thomas M Steenholdt
Modified: 2015-01-07 19:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-16 12:10:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas M Steenholdt 2002-09-10 02:32:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
pppd does not support xxx-filter options; this is due to the fact that the ppp
package does not build pppd with FILTER=y option set.
The option was traditionally disabled because linux aparrently did not support
this feature, but that is no longer the case and the default redhat kernels is
even compiled with the required options for this to work.
IMO you should enable ppp filtering in pppd by removing the comment char from
the "#FILTER=y" line in pppd-2.4.1/pppd/Makefile.linux
This will allow people to customize what kind of traffic should be allowed and
what is to be considered link activity... This is really useful for people like
myself, who runs a dial-up router configuration and have trouble with other
peoples misdirected traffic keeping the link up and thus costing then a lot of $

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start pppd with "active-filter 'outbound'" option
2. notice that it fails saying that an invalid option has been passed
3.
	

Actual Results:  pppd detects an invalid option

Expected Results:  pppd should start with filtering enabled

Additional info:

like i mentioned, the fix is to patch the ppp-2.4.1/pppd/Makefile.linux file to
uncomment the line reading "#FILTER=y" and thats it...

I noticed that after i did this at home, the ppp package required libpcap which
i believe it did not need before(iirc) but that's in your distribution too, so
no show stopper there...

Anyway - for people who do not need the filtering, leaving the options alone
should result in "normal" behaviour so I don't really see why(if) this should
not be easily fixable
Comment 1 Thomas M Steenholdt 2002-09-10 02:35:38 EDT
The same goes for RH 7.3 (possibly more) hope you guys can help redirrect this
information to those versions as well, if applicaple, or at least advise on what
I should do about it...

Comment 2 Thomas M Steenholdt 2002-10-04 03:02:59 EDT
Moving bug to RHL 8.0 - still an issue
Comment 3 Craig Kelley 2003-08-22 22:13:41 EDT
Dup of bug #71247
Comment 4 Thomas Woerner 2004-08-16 12:10:12 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.