Bug 737612 - Internal Server Error while attempting to upload kickstart file
Summary: Internal Server Error while attempting to upload kickstart file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning
Version: 541
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Tomas Lestach
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2011-09-12 17:43 UTC by mchlums
Modified: 2017-07-19 10:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-19 10:57:13 UTC


Attachments (Terms of Use)
Stack traces (17.11 KB, text/plain)
2011-09-12 17:43 UTC, mchlums
no flags Details

Description mchlums 2011-09-12 17:43:58 UTC
Created attachment 522743 [details]
Stack traces

Description of problem:

After attempting to upload a kickstart file via the RHN satellite administration page, the page displays:

Internal Server Error

The server experienced a problem which prevented your request from being filled out. It may not be possible to execute this action at this time.

Please help us correct this problem by contacting us with details of how you received this message




Version-Release number of selected component (if applicable):

cobbler-2.0.7-11.el6sat.noarch



How reproducible:

Occurs every time.


Steps to Reproduce:
1. Attempt to upload a kickstart file or use the wizard to create a kickstart profile


  
Actual results:

Get an error page (see description above).



Expected results:

Kickstart profile created.


Additional info:

I investigated and found this snippet in catalina.out (attached):

Caused by: 
redstone.xmlrpc.XmlRpcFault: <type 'exceptions.IOError'>:[Errno 13] Permission denied: '/var/lib/tftpboot/s390x/profile_list'


I found the following AVC in audit.log related to '/var/lib/tftpboot/s390x/profile_list':

type=AVC msg=audit(1315847043.101:5310): avc:  denied  { read write } for  pid=29292 comm="cobblerd" name="profile_list
" dev=dm-1 ino=5247090 scontext=system_u:system_r:cobblerd_t:s0 tcontext=unconfined_u:object_r:tftpdir_rw_t:s0 tclass=f
ile

Comment 2 Jan Pazdziora 2012-04-12 12:43:17 UTC
Please contact Red Hat support to help you with this issue.

I believe cobbler sync (maybe in Permissive) should fix your cobbler/tftpboot setup, especially if you have cobbler-2.0.7-11.el6sat or newer.

Comment 3 Tomas Lestach 2017-07-19 10:57:13 UTC
We have re-reviewed this bug, as part of an ongoing effort to improve  Satellite/Proxy feature and bug updates, review and backlog.

We believe this bug has been fixed in the latest Satellite 5 version (5.8), so closing the bug as CURRENTRELEASE. Please feel free to re-open in case you discover any issues.

Tomas


Note You need to log in before you can comment on or make changes to this bug.