Bug 737633 - lm_sensors /usr/bin/decode-dimms.pl does not support DDR3
Summary: lm_sensors /usr/bin/decode-dimms.pl does not support DDR3
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lm_sensors
Version: 5.7
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Jaromír Cápík
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-12 18:52 UTC by Dave Sullivan
Modified: 2016-02-01 01:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:00:37 UTC


Attachments (Terms of Use)

Description Dave Sullivan 2011-09-12 18:52:58 UTC
Description of problem:

lm_sensors contains decode-dimms.pl code, but it doesn't support decoding DDR3 spd.

http://en.wikipedia.org/wiki/Serial_presence_detect

Apparently upstream this perl script has been moved to i2c-tools

http://www.lm-sensors.org/wiki/I2CTools

However, ic2-tools is not included as part of RHEL5/RHEL6 or Fedora EPEL.

I do see a bz files dor the ic2-tools EPEL.

https://bugzilla.redhat.com/show_bug.cgi?id=724903

But would think that maybe it should be packaged as part of RHEL instead since it is part of lm_sensors in RHEL5 today.

FYI, you can get this same information using HP PSP hpdiags

hpdiags -v 5

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jaromír Cápík 2013-05-16 14:45:45 UTC
Hello Dave.

If the script's been moved to i2c-tools without changing its name, then it would definitely conflict with lm_sensors. We would have to introduce i2c-tools in a modified form and that isn't very nice solution, is it? We can't simply remove it from the lm_sensors, because that would cause a regression for those who don't want to install EPEL packages.
There's no easy way out of this. Any ideas?

Regards,
Jaromir.

Comment 2 RHEL Product and Program Management 2014-03-07 13:31:59 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 3 RHEL Product and Program Management 2014-06-02 13:00:37 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.