Bug 737636 - conductor crashes after cleanup/configure
Summary: conductor crashes after cleanup/configure
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-configure
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: rc
Assignee: Mike Orazi
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-12 18:57 UTC by wes hayutin
Modified: 2011-11-08 17:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-14 02:27:29 UTC


Attachments (Terms of Use)

Description wes hayutin 2011-09-12 18:57:56 UTC
Description of problem:

I've noticed this problem for a few weeks now.. This does seem to be some sort of a timing issue...

here is the thin.log


[root@nec-em16 ~]# cat /var/log/aeolus-conductor/thin.log
>> Writing PID to /var/run/aeolus-conductor/thin.pid
>> Changing process privilege to aeolus:aeolus
Rails Error: Unable to access log file. Please ensure that /usr/share/aeolus-conductor/log/production.log exists and is chmod 0666. The log level has been raised to WARN and the output directed to STDERR until the problem is fixed.
>> Thin web server (v1.2.11 codename Bat-Shit Crazy)
>> Maximum connections set to 1024
>> Listening on 127.0.0.1:3000, CTRL+C to stop
>> Stopping ...
>> Exiting!
>> Writing PID to /var/run/aeolus-conductor/thin.pid
>> Changing process privilege to aeolus:aeolus
Rails Error: Unable to access log file. Please ensure that /usr/share/aeolus-conductor/log/production.log exists and is chmod 0666. The log level has been raised to WARN and the output directed to STDERR until the problem is fixed.
>> Thin web server (v1.2.11 codename Bat-Shit Crazy)
>> Maximum connections set to 1024
>> Listening on 127.0.0.1:3000, CTRL+C to stop
>> Stopping ...
>> Exiting!
>> Writing PID to /var/run/aeolus-conductor/thin.pid
>> Changing process privilege to aeolus:aeolus
>> Using rails adapter
Rails Error: Unable to access log file. Please ensure that /usr/share/aeolus-conductor/log/production.log exists and is chmod 0666. The log level has been raised to WARN and the output directed to STDERR until the problem is fixed.
>> Exiting!
/usr/lib/ruby/gems/1.8/gems/activesupport-3.0.9/lib/active_support/dependencies.rb:239:in `require': no such file to load -- dispatcher (LoadError)
	from /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.9/lib/active_support/dependencies.rb:239:in `require'
	from /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.9/lib/active_support/dependencies.rb:227:in `load_dependency'
	from /usr/lib/ruby/gems/1.8/gems/activesupport-3.0.9/lib/active_support/dependencies.rb:239:in `require'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/rack/adapter/rails.rb:38:in `load_application'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/rack/adapter/rails.rb:23:in `initialize'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/rack/adapter/loader.rb:48:in `new'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/rack/adapter/loader.rb:48:in `for'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/controllers/controller.rb:169:in `load_adapter'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/controllers/controller.rb:73:in `start'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:185:in `send'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:185:in `run_command'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:151:in `run!'
	from /usr/lib/ruby/gems/1.8/gems/thin-1.2.11/bin/thin:6
	from /usr/bin/thin:19:in `load'
	from /usr/bin/thin:19
[root@nec-em16 ~]# 


This does not immediately go down.. 
http://hudson.rhq.lab.eng.bos.redhat.com:8080/hudson/view/DEV-CloudForms/job/public-cloudEngine-installConfig-fedora/178/TestNG_Report/

you can see in this job the last checks see aeolus-conductor as running.. 
If I wait several hours..
[root@nec-em16 ~]# uptime
 14:57:21 up  4:37,  1 user,  load average: 0.00, 0.01, 0.05

Conductor seems to crash for some reason.
A simple restart of aeolus-conductor resolves the issue

Comment 1 wes hayutin 2011-09-14 02:27:29 UTC
not a bug.. found the issue


Note You need to log in before you can comment on or make changes to this bug.