Bug 737704 - Fix spec file test script typo and enable running the test suites
Summary: Fix spec file test script typo and enable running the test suites
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nss
Version: 5.7
Hardware: i686
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Elio Maldonado Batiz
QA Contact: Hubert Kario
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-12 22:43 UTC by Steve Snyder
Modified: 2013-09-30 22:40 UTC (History)
2 users (show)

Fixed In Version: nss-3.14.3-4.el5 nspr-4.9.5-2.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-30 22:40:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
Fix typo and add check section to run the test suites (2.94 KB, patch)
2013-02-17 22:51 UTC, Elio Maldonado Batiz
rrelyea: review+
Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1318 normal SHIPPED_LIVE nss bug fix and enhancement update 2013-09-30 21:13:17 UTC

Description Steve Snyder 2011-09-12 22:43:04 UTC
Description of problem:

There is a typo in the scripting done while setting up the validation test for NSS.

Version-Release number of selected component (if applicable):

nss-3.12.10-4.el5_7.

How reproducible:

Always

Steps to Reproduce:
1. Rebuild from source RPM.
2. Note this error during build: 

   ~/TMP/rpm-tmp.91529: line 137: [: SPACEISBAD: integer expression expected

3.
  
Actual results:

Scripting fails due to syntax error

Expected results:

Syntax of shell scripts should be correct.

Additional info:

Line

if [ SPACEISBAD -ne 0 ]; then

is missing the dollar sign that should prepend the variable name, i.e.:

if [ $SPACEISBAD -ne 0 ]; then

Comment 1 Elio Maldonado Batiz 2011-09-14 19:00:15 UTC
(In reply to comment #0)
> if [ SPACEISBAD -ne 0 ]; then
> is missing the dollar sign that should prepend the variable name, i.e.:
> if [ $SPACEISBAD -ne 0 ]; then

You are right, it's on 5 and 4, fixed on 6.

[....]$ grep -r "SPACEISBAD -ne" .
./RHEL-4/nss.spec:if [ SPACEISBAD -ne 0 ]; then
./RHEL-5/nss.spec:if [ $SPACEISBAD -ne 0 ]; then
./RHEL-6/nss.spec:if [ $SPACEISBAD -ne 0 ]; then
./RHEL-6/nss.spec~:if [ $SPACEISBAD -ne 0 ]; then
./RHEL-6_1-Z/nss.spec:if [ $SPACEISBAD -ne 0 ]; then
./RHEL-6_0-Z/nss.spec:if [ SPACEISBAD -ne 0 ]; then
./RHEL-5_7-Z/nss.spec:if [ SPACEISBAD -ne 0 ]; then
./RHEL-5_6-Z/nss.spec:if [ SPACEISBAD -ne 0 ]; then
./RHEL-5_5-Z/nss.spec:if [ SPACEISBAD -ne 0 ]; then
./RHEL-5_4-Z/nss.spec:if [ SPACEISBAD -ne 0 ]; then

Comment 2 RHEL Product and Program Management 2012-06-12 01:32:50 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 3 Elio Maldonado Batiz 2013-02-17 22:29:35 UTC
Fixing this bug should not affect validation as we aren't touching the cryptographic module in a any neither the code nor the way it is built. Fix this is also needed to enable running the upstream test suite which have been disabled for some other reasons. Because we are using the nss internal cryptomusle in softoken/freebl from nss-3.15, the FIPS-140 validated one, which lacks support for the sqlite-based shared db and using some test tools from that release we won't be able to run some of the test but we can run must of them and we should. We should expand the scope of this bug to enable running as much of the upstream test suite as possible. I I'll attach the proposed modifications to the nss.spec file next.

Comment 4 Elio Maldonado Batiz 2013-02-17 22:51:04 UTC
Created attachment 698646 [details]
Fix typo and add check section to run the test suites

Comment 5 Bob Relyea 2013-02-20 19:19:38 UTC
dev_ack+ for 5.10... I'd also removed the commented lines about turning off optimizations that have nothing to do with this bug (but they are commented out, so they don't hurt).

bob

Comment 6 Bob Relyea 2013-04-01 22:23:20 UTC
Comment on attachment 698646 [details]
Fix typo and add check section to run the test suites

r+ but see comment 5

Comment 7 RHEL Product and Program Management 2013-04-04 12:37:17 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 9 Elio Maldonado Batiz 2013-06-18 15:40:51 UTC
This has been fixed as part of the rebase to nss-3.14.3 requested on Bug 918948.
Marking ii on nss-3.14.3-2.el5 as this was the first build with the test suites enabled on the check section.

Comment 11 Elio Maldonado Batiz 2013-07-01 14:59:09 UTC
Running of the nspr test suite added to the %check section of nspr.spec as well.

Comment 14 errata-xmlrpc 2013-09-30 22:40:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1318.html


Note You need to log in before you can comment on or make changes to this bug.