Bug 737730 - Provide native systemd services
Summary: Provide native systemd services
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: uucp
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-12 23:41 UTC by Jóhann B. Guðmundsson
Modified: 2011-09-30 18:43 UTC (History)
2 users (show)

Fixed In Version: uucp-1.07-26.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-13 10:47:04 UTC


Attachments (Terms of Use)
uucp socket (127 bytes, text/plain)
2011-09-12 23:42 UTC, Jóhann B. Guðmundsson
no flags Details
uucp service (129 bytes, text/plain)
2011-09-12 23:42 UTC, Jóhann B. Guðmundsson
no flags Details

Description Jóhann B. Guðmundsson 2011-09-12 23:41:23 UTC
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jóhann B. Guðmundsson 2011-09-12 23:42:07 UTC
Created attachment 522833 [details]
uucp socket

Comment 2 Jóhann B. Guðmundsson 2011-09-12 23:42:49 UTC
Created attachment 522834 [details]
uucp service

Comment 3 Jóhann B. Guðmundsson 2011-09-12 23:43:19 UTC
Once package and shipped your package should no longer have to depend on xinetd

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd

Comment 4 Ondrej Vasik 2011-09-13 05:22:45 UTC
Thanks for the report and systemd scriptlets, Jóhann.

Comment 6 Fedora Update System 2011-09-13 12:28:01 UTC
uucp-1.07-26.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/uucp-1.07-26.fc16

Comment 7 Nils Philippsen 2011-09-14 11:24:12 UTC
This works for me on F-16 with systemd-34. With systemd-35, it doesn't. I'll talk to systemd upstream about it.

Comment 8 Nils Philippsen 2011-09-14 12:07:02 UTC
Apparently systemd-35 changed the default of where stdin, stdout are connected for socket activated services, previously it did the right thing. Version 36 is supposed to fix this:

http://thread.gmane.org/gmane.comp.sysutils.systemd.devel/3267/focus=3269

A workaround for testing this with systemd-35 is to add this to the Service section of uucp@.service:

StandardOutput=socket

Comment 9 Ondrej Vasik 2011-09-14 12:18:08 UTC
Thanks for info, Nils, I got this information from Petr Lautrbach already - is it necessary to rebuild the uucp packages in f16/f17 or this will no longer be required with systemd-36 ?

Comment 10 Jóhann B. Guðmundsson 2011-09-14 12:21:15 UTC
I would recommend just to wait after .36

Comment 11 Fedora Update System 2011-09-30 18:43:04 UTC
uucp-1.07-26.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.