Bug 737757 - mkisofs -sort filename ( where file contents is empty) breaks iso file
Summary: mkisofs -sort filename ( where file contents is empty) breaks iso file
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: cdrkit
Version: 14
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Honza Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 02:54 UTC by U George
Modified: 2011-09-27 11:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-27 11:34:35 UTC


Attachments (Terms of Use)

Description U George 2011-09-13 02:54:12 UTC
Description of problem:
i am running k3b to create data files on a blu-ray writer.

There is only one file to be written, a slightly less than 25gig( decimal) tar file.

My first attempt failed, as the tar file was unreadable:
 Sep 12 16:21:56 AsusG73sw kernel: [108597.636613] attempt to access beyond end of device
Sep 12 16:21:56 AsusG73sw kernel: [108597.636617] sr0: rw=0, want=48829724, limit=48829720
Sep 12 16:21:56 AsusG73sw kernel: [108597.636618] Buffer I/O error on device sr0, logical block 12207430
Sep 12 16:21:56 AsusG73sw kernel: [108597.636622] attempt to access beyond end of device
Sep 12 16:21:56 AsusG73sw kernel: [108597.636623] sr0: rw=0, want=48829728, limit=48829720
Sep 12 16:21:56 AsusG73sw kernel: [108597.636625] Buffer I/O error on device sr0, logical block 12207431

After much reading, someone suggested that the "-sort" option causes the failure. In my case the sort file is empty ( but exists ).
I then created the .iso file using just the mkisofs command that k3b used, as shown in the k3b log file.
I can mount the .iso file via the loop mechanism, and tar can go through the multi-volume tar backup set.

Version-Release number of selected component (if applicable):
[root@AsusG73sw vixia]# mkisofs -version
mkisofs 3.01a05 (x86_64-unknown-linux-gnu) Copyright (C) 1993-1997 Eric Youngdale (C) 1997-2010 Joerg Schilling


How reproducible:

Not sure, every coaster costs $1.20 to experiment with.
Steps to Reproduce:
1./usr/bin/mkisofs -gui -graft-points -volid Canon_Vixia_1 -volset  -appid="K3B THE CD KREATOR (C) 1998-2010 SEBASTIAN TRUEG AND MICHAL MALEK" -publisher  -preparer  -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-gat/k3bst4708.tmp -rational-rock -hide-list /tmp/kde-gat/k3bLB4708.tmp -no-cache-inodes -udf -full-iso9660-filenames -iso-level 3 -path-list /tmp/kde-gat/k3bsa4708.tmp >a.iso

where "k3bsa4708.tmp" contains Canon_Vixia_2.tar=/tmp/Canon_Vixia_1.tar
the other files are empty.
2.
3.
  
Actual results: 
.iso file can be mounted. 
od -c of the tar file shows that the tar header is broken/damaged. I suppose this is a result of the kernel catching some seek error, and returning a bogus buffer.

Expected results:
can read the tar file  without error.

Additional info:
Its apparent that mkisofs is broken when using the "-sort" option. 
There is no way to tell k3b that "sort" is broken in mkisofs, and not use it.

Comment 1 Honza Horak 2011-09-20 16:19:44 UTC
Thanks for reporting, I've tried to reproduce this failure with genisoimage-1.1.11-8.fc15.x86_64, but it works fine.

(In reply to comment #0)
> # mkisofs -version
> mkisofs 3.01a05 (x86_64-unknown-linux-gnu) Copyright (C) 1993-1997 Eric
> Youngdale (C) 1997-2010 Joerg Schilling

It seems you have installed cdrtools from cdrecord.berlios.de, which is not in Fedora at all (cdrkit's upstream is www.cdrkit.org). 

Please, contact author of cdrtools.

Comment 2 Honza Horak 2011-09-27 11:34:35 UTC
Closing this bug for now, since it works fine for me. 
Please, feel free to re-open it if the failure occurs in the Fedora package.


Note You need to log in before you can comment on or make changes to this bug.