Bug 737762 - subscription-manager register with --autosubscribe fails against stage on a rhel-6-server system
subscription-manager register with --autosubscribe fails against stage on a r...
Status: CLOSED CURRENTRELEASE
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.5
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-09-12 23:27 EDT by John Sefler
Modified: 2015-05-14 11:22 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 09:14:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-09-12 23:27:31 EDT
Description of problem:
Contrary to what was once reported as working in bug 734867, the register with --autosubscribe is no longer working against the staged candlepin server.


Version-Release number of selected component (if applicable):
[root@jsefler-stage-6server ~]# rpm -q subscription-manager
subscription-manager-0.96.9-1.el6.x86_64
[root@jsefler-stage-6server ~]# rpm -q python-rhsm
python-rhsm-0.96.11-1.el6.noarch


How reproducible:


Steps to Reproduce:
[root@jsefler-stage-6server ~]# ls /etc/pki/product/
69.pem
[root@jsefler-stage-6server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux 6 Server
Status:             	Not Subscribed           
Expires:            	                         
SerialNumber:       	                         
ContractNumber:     	                         
AccountNumber:      	                         

[root@jsefler-stage-6server ~]# subscription-manager register --username=stage_test_12 --password=redhat --autosubscribe
The system has been registered with id: 19b434f1-b201-4ea3-a19a-9e9563401e9f 


^^^^ THAT SHOULD HAVE AUTOSUBSCRIBE TO A SUBSCRIPTION THAT PROVIDES rhel-6-server.
FOLLOWING IS MY MANUAL SUBSCRIBE EVIDENCE THAT THE SAME CONSUMER HAD ACCESS TO A SUBSCRIPTION THAT SATISFIED THE PRODUCT


[root@jsefler-stage-6server ~]# subscription-manager list --available
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+


ProductName:       	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to
                        4 guests)
ProductId:         	RH0103708                
PoolId:            	8a99f981308acf4201308b9ad4a41d37
Quantity:          	92                       
Multi-Entitlement: 	No                       
Expires:           	06/08/2012               
MachineType:       	physical                 


ProductName:       	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to
                        4 guests)
ProductId:         	RH0103708                
PoolId:            	8a99f981308acf4201308b9ad7101d3a
Quantity:          	397                      
Multi-Entitlement: 	No                       
Expires:           	06/08/2012               
MachineType:       	virtual                  


ProductName:       	Red Hat Enterprise Linux Advanced Platform, Standard L3
                        (unlimited sockets)
ProductId:         	MCT1035                  
PoolId:            	8a99f981308acf4201309911639a0c51
Quantity:          	96                       
Multi-Entitlement: 	No                       
Expires:           	06/15/2012               
MachineType:       	physical                 


ProductName:       	Red Hat Enterprise Linux Advanced Platform, Standard L3
                        (unlimited sockets)
ProductId:         	MCT1035                  
PoolId:            	8a99f981308acf420130991163ac0c56
Quantity:          	unlimited                
Multi-Entitlement: 	No                       
Expires:           	06/15/2012               
MachineType:       	virtual                  

[root@jsefler-stage-6server ~]# subscription-manager subscribe --pool=8a99f981308acf4201308b9ad4a41d37
Successfully subscribed the system to Pool 8a99f981308acf4201308b9ad4a41d37
[root@jsefler-stage-6server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux Server
Status:             	Subscribed               
Expires:            	06/08/2012               
SerialNumber:       	6299842867989948149      
ContractNumber:     	2394344                  
AccountNumber:      	1465502     


^^^ THERE IT IS, A MANUAL SUBSCRIBE ACTUALLY COVERED THE INSTALLED PRODUCT, BUT THE REGISTER WITH --autosubscribe DID NOT WORK.
Comment 4 James Bowes 2011-10-03 11:47:08 EDT
I believe this is fixed server side, in candlepin master, 65a89acd.
Comment 7 yu zheng 2011-10-11 03:10:44 EDT
Tested against the staged candlepin server: FAIL

Version-Release number:
RHEL6.2-Snapshot-1(x86_84)
subscription-manager-0.96.13-1.el6.x86_64
python-rhsm-0.96.13-1.el6.noarch

Steps to Reproduce:
1.list installed products
[root@unused-2-227 ~]# subscription-manager list
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux Server
Version:            	6.2 Beta                 
Arch:               	x86_64                   
Status:             	Not Subscribed           
Starts:             	                         
Expires:           	                              
2.autosubscribe during registering
[root@unused-2-227 ~]# subscription-manager register --autosubscribe --username=stage_test_12 --password=redhat
The system has been registered with id: 33d8a5dc-a00e-4f3b-883b-d46c9f3d4140 
Installed Product Current Status:

ProductName:         	Red Hat Enterprise Linux Server
Status:               	Not Subscribed
                        ^^^^^^^^^^^^^^^The autosubscribe doesn't work.
Addition info:
1.register and list available subscriptions
[root@unused-2-227 ~]# subscription-manager list --available
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+

ProductName:       	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to
                        4 guests)
ProductId:         	RH0103708                
PoolId:            	8a99f981308acf4201308b9ad4a41d37
Quantity:          	87                       
Multi-Entitlement: 	No                       
Expires:           	06/08/2012               
MachineType:       	physical                 
                        ^^^^^^^^^The subscription is available.
ProductName:       	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to
                        4 guests)
ProductId:         	RH0103708                
PoolId:            	8a99f981308acf4201308b9ad7101d3a
Quantity:          	392                      
Multi-Entitlement: 	No                       
Expires:           	06/08/2012               
MachineType:       	virtual                  

ProductName:       	Red Hat Enterprise Linux Advanced Platform, Standard L3
                        (unlimited sockets)
ProductId:         	MCT1035                  
PoolId:            	8a99f981308acf4201309911639a0c51
Quantity:          	96                       
Multi-Entitlement: 	No                       
Expires:           	06/15/2012               
MachineType:       	physical                 

ProductName:       	Red Hat Enterprise Linux Advanced Platform, Standard L3
                        (unlimited sockets)
ProductId:         	MCT1035                  
PoolId:            	8a99f981308acf420130991163ac0c56
Quantity:          	unlimited                
Multi-Entitlement: 	No                       
Expires:           	06/15/2012               
MachineType:       	virtual  
2.check socket number
[root@unused-2-227 ~]# subscription-manager facts --list
cpu.core(s)_per_socket: 1
cpu.cpu(s): 1
cpu.cpu_socket(s): 1
......
Comment 8 John Sefler 2011-10-12 10:42:45 EDT
I agree with comment 7, this is still failing.
I suspect part of the reason this is failing is because the repos that provide content for 69.pem/"6.2 Beta" are actually disabled by default.

If I manually subscribe to RH0103708, you will see that the 69.pem for "6.2 Beta" will be Subscribed yet the repo "rhel-6-server-beta-rpms" is disabled by default



[root@tyan-gt24-01 ~]# subscription-manager  list --avail
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+


ProductName:       	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to
                        4 guests)
ProductId:         	RH0103708                
PoolId:            	8a99f981308acf4201308bd11b8a2e15
Quantity:          	83                       
Multi-Entitlement: 	No                       
Expires:           	06/12/2012               
MachineType:       	physical                 


ProductName:       	High-Availability (8 sockets)
ProductId:         	RH1149049                
PoolId:            	8a99f981308acf4201308e46f6a167d2
Quantity:          	87                       
Multi-Entitlement: 	No                       
Expires:           	06/13/2012               
MachineType:       	physical                 


ProductName:       	Red Hat Enterprise Linux Desktop, Basic
ProductId:         	MCT0995                  
PoolId:            	8a99f981308acf4201308fd6e7166a35
Quantity:          	95                       
Multi-Entitlement: 	No                       
Expires:           	06/13/2012               
MachineType:       	physical                 

[root@tyan-gt24-01 ~]# subscription-manager  subscribe --pool=8a99f981308acf4201308bd11b8a2e15
Successfully subscribed the system to Pool 8a99f981308acf4201308bd11b8a2e15


[root@tyan-gt24-01 ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux Server
Version:            	6.2 Beta                 
Arch:               	i386                     
Status:             	Subscribed               
Starts:             	06/13/2011               
Expires:            	06/12/2012    


[root@tyan-gt24-01 ~]# subscription-manager repos --list
+----------------------------------------------------------+
    Entitled Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+

RepoName:            	Red Hat Enterprise Linux 6 Server - Supplementary Beta (Debug RPMs)
RepoId:              	rhel-6-server-supplementary-beta-debuginfo
RepoUrl:             	https://cdn.redhat.com/content/beta/rhel/server/6/$releasever/$basearch/supplementary/debug
Enabled:             	0                        


RepoName:            	Red Hat Enterprise Linux 6 Server - Optional Beta (Debug RPMs)
RepoId:              	rhel-6-server-optional-beta-debug-rpms
RepoUrl:             	https://cdn.redhat.com/content/beta/rhel/server/6/$releasever/$basearch/optional/debug
Enabled:             	0                        


RepoName:            	Red Hat Enterprise Linux 6 Server Beta (Debug RPMs)
RepoId:              	rhel-6-server-beta-debug-rpms
RepoUrl:             	https://cdn.redhat.com/content/beta/rhel/server/6/$releasever/$basearch/debug
Enabled:             	0                        


RepoName:            	Red Hat Enterprise Linux 6 Server (Debug RPMs)
RepoId:              	rhel-6-server-debug-rpms 
RepoUrl:             	https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/debug
Enabled:             	0                        


RepoName:            	Red Hat Enterprise Linux 6 Server - Supplementary Beta (Source RPMs)
RepoId:              	rhel-6-server-supplementary-beta-src
RepoUrl:             	https://cdn.redhat.com/content/beta/rhel/server/6/$releasever/$basearch/supplementary/source/SRPMS
Enabled:             	0                        


RepoName:            	Red Hat Enterprise Linux 6 Server (RPMs)
RepoId:              	rhel-6-server-rpms       
RepoUrl:             	https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/os
Enabled:             	1                        


RepoName:            	Red Hat Enterprise Linux 6 Server (Source RPMs)
RepoId:              	rhel-6-server-source-rpms
RepoUrl:             	https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/source/SRPMS
Enabled:             	0                        


RepoName:            	Red Hat Enterprise Linux 6 Server - Optional (Source RPMs)
RepoId:              	rhel-6-server-optional-source-rpms
RepoUrl:             	https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/optional/source/SRPMS
Enabled:             	0                        


RepoName:            	Red Hat Enterprise Linux 6 Server - Optional Beta (RPMs)
RepoId:              	rhel-6-server-optional-beta-rpms
RepoUrl:             	https://cdn.redhat.com/content/beta/rhel/server/6/$releasever/$basearch/optional/os
Enabled:             	0                        


RepoName:            	Red Hat Enterprise Linux 6 Server Beta (Source RPMs)
RepoId:              	rhel-6-server-beta-source-rpms
RepoUrl:             	https://cdn.redhat.com/content/beta/rhel/server/6/$releasever/$basearch/source/SRPMS
Enabled:             	0                        


RepoName:            	Red Hat Enterprise Linux 6 Server Beta (RPMs)
RepoId:              	rhel-6-server-beta-rpms  
RepoUrl:             	https://cdn.redhat.com/content/beta/rhel/server/6/$releasever/$basearch/os
Enabled:             	0                        


RepoName:            	Red Hat Enterprise Linux 6 Server - Supplementary (RPMs)
RepoId:              	rhel-6-server-supplementary
RepoUrl:             	https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/supplementary/os
Enabled:             	0                        


RepoName:            	Red Hat Enterprise Linux 6 Server - Optional Beta (Source RPMs)
RepoId:              	rhel-6-server-optional-beta-source-rpms
RepoUrl:             	https://cdn.redhat.com/content/beta/rhel/server/6/$releasever/$basearch/optional/source/SRPMS
Enabled:             	0                        


RepoName:            	Red Hat Enterprise Linux 6 Server - Supplementary (Debug RPMs)
RepoId:              	rhel-6-server-supplementary-debuginfo
RepoUrl:             	https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/supplementary/debug
Enabled:             	0                        


RepoName:            	Red Hat Enterprise Linux 6 Server - Optional (Debug RPMs)
RepoId:              	rhel-6-server-optional-debug-rpms
RepoUrl:             	https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/optional/debug
Enabled:             	0                        


RepoName:            	Red Hat Enterprise Linux 6 Server - Supplementary (Source RPMs)
RepoId:              	rhel-6-server-supplementary-src
RepoUrl:             	https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/supplementary/source/SRPMS
Enabled:             	0                        


RepoName:            	Red Hat Enterprise Linux 6 Server - Supplementary Beta (RPMs)
RepoId:              	rhel-6-server-supplementary-beta
RepoUrl:             	https://cdn.redhat.com/content/beta/rhel/server/6/$releasever/$basearch/supplementary/os
Enabled:             	0                        


RepoName:            	Red Hat Enterprise Linux 6 Server - Optional (RPMs)
RepoId:              	rhel-6-server-optional-rpms
RepoUrl:             	https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/optional/os
Enabled:             	0                        
           
[root@tyan-gt24-01 ~]# yum repolist --disablerepo=beaker*Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.
rhel-6-server-rpms                                       | 2.4 kB     00:00     
rhel-6-server-rpms/primary                               | 4.1 MB     00:01     
rhel-6-server-rpms                                                    4172/4172
repo id                   repo name                                       status
rhel-6-server-rpms        Red Hat Enterprise Linux 6 Server (RPMs)        4,172
repolist: 4,172
[root@tyan-gt24-01 ~]# 


^^^ SEE.. NONE OF THE rhel-6-server-beta-* REPOS ARE ENABLED.

ONE POTENTIAL FIX IS TO HAVE FOR dgregor TO ENABLE THE BETA REPOS.  HOWEVER, I SUSPECT THAT WILL LEAD US TO BUG 743667.

Moving back to NEW/FailedQA
Comment 10 John Sefler 2011-10-31 08:53:31 EDT
Forget the repo "rhel-6-server-beta-rpms" harangue in comment 8.  That issue is better left to bug 743667.


Verifying this bug...

With the deployment of candlepin 0.4.25 to the stage environment, this bug is fixed as demonstrated below....

[root@intel-s3ea2-04 ~]# rpm -q subscription-manager
subscription-manager-0.96.17-1.el6.x86_64


[root@intel-s3ea2-04 ~]# grep hostname /etc/rhsm/rhsm.conf 
# Server hostname:
hostname=subscription.rhn.stage.redhat.com
proxy_hostname=
[root@intel-s3ea2-04 ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux 6 Server
Version:            	6.1                      
Arch:               	x86_64                   
Status:             	Not Subscribed           
Starts:             	                         
Expires:            	                         


[root@intel-s3ea2-04 ~]# subscription-manager register --username stage_test_12 --password redhat --autosubscribe
The system has been registered with id: 11f57578-0840-459e-be37-fe6453305b1e 
Installed Product Current Status:

ProductName:         	Red Hat Enterprise Linux 6 Server
Status:               	Subscribed               

[root@intel-s3ea2-04 ~]# subscription-manager list --consumed
+-------------------------------------------+
    Consumed Product Subscriptions
+-------------------------------------------+


ProductName:        	Red Hat Enterprise Linux Server
ContractNumber:     	2635037                  
AccountNumber:      	1508113                  
SerialNumber:       	9101562701666144569      
Active:             	True                     
QuantityUsed:       	1                        
Begins:             	10/19/2011               
Expires:            	10/18/2012               

[root@intel-s3ea2-04 ~]# 

Moving to VERIFIED
Comment 11 Vratislav Podzimek 2012-11-08 07:35:19 EST
*** Bug 873767 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.