Bug 737799 - [RFE] putproject should use attributes defined in zanata.xml
Summary: [RFE] putproject should use attributes defined in zanata.xml
Keywords:
Status: CLOSED DUPLICATE of bug 906667
Alias: None
Product: Zanata
Classification: Retired
Component: Component-Maven
Version: 1.4-RC
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: zanata-dev-internal
QA Contact: Ding-Yi Chen
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 07:04 UTC by Ding-Yi Chen
Modified: 2013-02-01 07:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 07:09:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 737806 None None None Never

Internal Links: 737806

Description Ding-Yi Chen 2011-09-13 07:04:29 UTC
Description of problem:
For maven client, attributes such as url, project, project-version in zanata.xml are not used on goal putproject.

Administrators do not have to type all the information which already contained in zanata.xml 

How reproducible:
Always

Version-Release number of selected component (if applicable):


Steps to Reproduce:
1. Assume zanata.xml is:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<config xmlns="http://zanata.org/namespace/config/">

    <url>http://zanata.server.com/</url>

    <project>AboutFedora</project>

    <project-version>f13</project-version>

    <locales>

        <locale map-from="ja-JP">ja</locale>

        <locale map-from="zh-CN">zh-Hans</locale>

    </locales>

</config>


2. Assume zanata.ini has following line:

zanata_1_4_auto.url=http://zanata.server.com/

zanata_1_4_auto.username=admin

zanata_1_4_auto.key=b6d7044e9ee3b2447c28fb7c50d86d98



3. mvn -e zanata:putproject  "-Dzanata.projectName=About Fedora" "-Dzanata.projectDesc=Desc of About Fedora" 

Actual results:
[ERROR] Failed to execute goal org.zanata:zanata-maven-plugin:1.4-SNAPSHOT:putproject (default-cli) on project null: The parameters 'projectDesc', 'projectSlug', 'projectName' for goal org.zanata:zanata-maven-plugin:1.4-SNAPSHOT:putproject are missing or invalid -> [Help 1]

org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.zanata:zanata-maven-plugin:1.4-SNAPSHOT:putproject (default-cli) on project null: The parameters 'projectDesc', 'projectSlug', 'projectName' for goal org.zanata:zanata-maven-plugin:1.4-SNAPSHOT:putproject are missing or invalid




Expected results:
Project AboutFedora should be create in zanata server.


Additional info:

Comment 1 Sean Flanigan 2011-10-17 03:24:10 UTC
The testing commands putversion, putuser and putproject don't support
zanata.xml, and it's not entirely trivial to implement.  You do have the option
of putting the parameters into pom.xml.

But if you want this, it should be an enhancement request.

Comment 2 Ding-Yi Chen 2013-02-01 07:09:25 UTC

*** This bug has been marked as a duplicate of bug 906667 ***


Note You need to log in before you can comment on or make changes to this bug.