Bug 737863 - arts binary rpm includes .la libtool development files
Summary: arts binary rpm includes .la libtool development files
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: arts
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 09:56 UTC by Henrik Nordström
Modified: 2011-09-13 19:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-13 15:08:17 UTC


Attachments (Terms of Use)

Description Henrik Nordström 2011-09-13 09:56:31 UTC
Description of problem:

The main arts binary rpm includes libtool .la development files which according to packaging guidelines should not be packaged in Fedora. (but which may need to stay packaged during a stable release)

Version-Release number of selected component (if applicable):

arts-1.5.10-13.fc15.x86_64.rpm

How reproducible:

always

Steps to Reproduce:
1. yum install arts
2. ls /usr/lib[64]/*.la
  
Actual results:

Several .la files installed all belonging to arts

Expected results:

No .la files found

Additional info:

http://fedoraproject.org/wiki/Packaging:Guidelines  section "Packaging Static libraries"

Comment 1 Kevin Kofler 2011-09-13 15:08:17 UTC
This is KDE 3 stuff, it requires .la files for plugins loaded at runtime.

Comment 2 Henrik Nordström 2011-09-13 19:29:41 UTC
A comment in the %files section in the spec to why the package deviates from packaging guidelines would be helpful.


Note You need to log in before you can comment on or make changes to this bug.