Bug 737899 - icedtea-web package changes /usr/bin permissions to 755
Summary: icedtea-web package changes /usr/bin permissions to 755
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: icedtea-web
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Deepak Bhole
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-13 11:11 UTC by Karel Srot
Modified: 2011-12-06 15:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 15:10:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1624 normal SHIPPED_LIVE icedtea-web enhancement update 2011-12-06 00:50:55 UTC

Description Karel Srot 2011-09-13 11:11:47 UTC
Description of problem:

Installation of icedtea-web package changes /usr/bin permissions from 555 to 755.
Is this required?

Changes are made with 
icedtea-web-1.1.1-1.el6.x86_64.rpm
icedtea-web-1.1.2-1.el6.x86_64.rpm
permissions are not changed with icedtea-web-1.0.4-2.el6_1.x86_64.rpm


How reproducible:
always

Steps to Reproduce:

[root@intel-d3c69-01 ~]# ls -ld /usr/bin
dr-xr-xr-x. 2 root root 94208 Sep 13 07:05 /usr/bin
[root@intel-d3c69-01 ~]# rpm -i icedtea-web-1.0.4-2.el6_1.x86_64.rpm 
[root@intel-d3c69-01 ~]# ls -ld /usr/bin
dr-xr-xr-x. 2 root root 94208 Sep 13 07:06 /usr/bin
[root@intel-d3c69-01 ~]# rpm -e icedtea-web
[root@intel-d3c69-01 ~]# rpm -i icedtea-web-1.1.1-1.el6.x86_64.rpm 
[root@intel-d3c69-01 ~]# ls -ld /usr/bin
drwxr-xr-x. 2 root root 94208 Sep 13 07:05 /usr/bin
[root@intel-d3c69-01 ~]# rpm -e icedtea-web
[root@intel-d3c69-01 ~]# chmod u-w /usr/bin
[root@intel-d3c69-01 ~]# ls -ld /usr/bin
dr-xr-xr-x. 2 root root 94208 Sep 13 07:05 /usr/bin
[root@intel-d3c69-01 ~]# rpm -i icedtea-web-1.1.2-1.el6.x86_64.rpm
[root@intel-d3c69-01 ~]# ls -ld /usr/bin
drwxr-xr-x. 2 root root 94208 Sep 13 07:06 /usr/bin

Comment 1 Deepak Bhole 2011-09-13 15:44:30 UTC
No, it was not intentional. I will fix it as soon as this has a +

Comment 5 errata-xmlrpc 2011-12-06 15:10:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1624.html


Note You need to log in before you can comment on or make changes to this bug.