Bug 737929 - topology set to sockets=3,cores=1,threads=1 but win7 only uses 2
Summary: topology set to sockets=3,cores=1,threads=1 but win7 only uses 2
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Eduardo Habkost
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 833130
TreeView+ depends on / blocked
 
Reported: 2011-09-13 12:17 UTC by zhe peng
Modified: 2014-04-08 18:13 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-08 18:13:42 UTC


Attachments (Terms of Use)
debug info (4.33 KB, text/plain)
2011-09-27 09:12 UTC, zhe peng
no flags Details
/var/log/libvirt/qemu/win7.log (1.86 KB, text/plain)
2011-09-27 09:25 UTC, zhe peng
no flags Details
new_debuginfo (8.02 KB, text/plain)
2011-09-28 05:21 UTC, zhe peng
no flags Details
/var/log/libvirt/qemu/win7.log (2.85 KB, text/plain)
2011-09-28 05:24 UTC, zhe peng
no flags Details

Description zhe peng 2011-09-13 12:17:53 UTC
Description of problem:
can't set correct vcpus for windows vm

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-6.el6
libvirt-0.9.4-11.el6
qemu-kvm-0.12.1.2-2.184.el6


How reproducible:
always

Steps to Reproduce:

  1:make sure host have 4 cpus
  2:create a windows vm
  3:change vm vcpus to 3
  4:start windows vm

Actual results:
login windows,open windows task Manager and switch to "performance" tab,only have 2 cpus,in win7, can open resource manager to check cpu number.

Expected results:
should have 3 vcpus

Additional info:
if set cpu topology manually:
 Open guest details page, Click Processor ->Topology, Tick Manual set cpu topology, then restart the vm , login windows will shown 3 cpus.
only occur on win7 winxp ,not on rhel and win2003.

Comment 2 Cole Robinson 2011-09-27 00:47:26 UTC
Please provide virt-manager --debug and /var/log/libvirt/qemu/$vmname.log output when reproducing this issue.

Comment 3 zhe peng 2011-09-27 09:12:15 UTC
Created attachment 525061 [details]
debug info

Comment 4 zhe peng 2011-09-27 09:25:16 UTC
Created attachment 525064 [details]
/var/log/libvirt/qemu/win7.log

Comment 5 Cole Robinson 2011-09-27 18:39:40 UTC
What version of windows 7 is this?

So if you start the guest with vcpus=3, and no explicit topology set in the UI, windows only sees 2 cpus. But if you then set manual topology in the UI to have 3 sockets, reboot the guest, windows now sees 3 cpus?

The log files you posted aren't exhaustive, they don't seem to show any topology or vcpu changes from virt-manager at least. Can you regenerate the logs, like:

- start virt-manager
- verify win7 is stopped
- change win7 to 1 vcpu, no topology
- start win7, verify see 1 cpu
- stop win7
- change win7 to 3 vcpu, no topology
- start win7, verify you see only 2 cpus
- stop win7
- change win7 to 3 vcpu, topology sockets=3, cores=1, threads=1
- start win7, verify you see only 3 cpus

Comment 6 zhe peng 2011-09-28 05:20:06 UTC
windows7 Ultimate build is 7600
i set topology as 3 sockets,1 cores,1 threads,start vm and login windows
from resource monitor,only have 2 cpus
from system info:
Processor:QEMU Virtual CPU version(cpu64-rhel6) 2.83GHz (2 processors)
but in Device manager,there have 3 QEMU Virtual CPU list under Processors

Comment 7 zhe peng 2011-09-28 05:21:41 UTC
Created attachment 525264 [details]
new_debuginfo

Comment 8 zhe peng 2011-09-28 05:24:55 UTC
Created attachment 525265 [details]
/var/log/libvirt/qemu/win7.log

Comment 9 RHEL Product and Program Management 2011-10-07 16:11:15 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 10 Cole Robinson 2011-10-13 18:17:29 UTC
Okay, reassigning to qemu-kvm then.


Note You need to log in before you can comment on or make changes to this bug.