Bug 737951 - no 32-bit glibc-utils on 64-bit machines
Summary: no 32-bit glibc-utils on 64-bit machines
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Schwab
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 13:25 UTC by Ulrich Drepper
Modified: 2016-11-24 15:40 UTC (History)
4 users (show)

Fixed In Version: glibc-2.14.90-12.999
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-19 04:34:11 UTC


Attachments (Terms of Use)
patch to spec (4.26 KB, patch)
2011-09-17 02:29 UTC, Jon Stanley
no flags Details | Diff

Description Ulrich Drepper 2011-09-13 13:25:03 UTC
Description of problem:
64-bit machines (particularly x86-64) don't have to possibility to install the 32-bit version of the package.  That is needed because glibc-utils contains libmemusage.so.  Running memusage on x86-64 on a 32-bit binary won't work.

Version-Release number of selected component (if applicable):
2.14 and everything because

How reproducible:
always

Steps to Reproduce:
1.create 32-bit binary
2.run memusage binary
3.
  
Actual results:
ERROR: ld.so: object '/usr/$LIB/libmemusage.so' from LD_PRELOAD cannot be preloaded: ignored.

Expected results:
No message, it just works.

Additional info:

Comment 1 Jon Stanley 2011-09-13 14:36:53 UTC
I tried installing the 32-bit on a 64-bit machine, and it won't work since /usr/bin/mtrace differs (the address widths printed are different). It would work if we could split out the DSO's from this package into glibc-utils-libs and leave the correct scripts on for the system in question.

Comment 2 Jon Stanley 2011-09-17 02:29:45 UTC
Created attachment 523672 [details]
patch to spec

I've attached a patch which resolves this. Let me know if this is OK to push.

Comment 3 Jon Stanley 2011-09-17 02:50:07 UTC
Comment on attachment 523672 [details]
patch to spec

That patch does not work (has git garbage interspersed from merge conflicts between master and f16 where I see most development has been happening lately)

Moreover, the problem is fixed in the f16 branch by having the libraries included in the (main) glibc pacakge so that we get around this issue.

HEAD however is broken, as is F15. See http://koji.fedoraproject.org/koji/rpminfo?rpmID=2690378

RHEL6 is also broken, but I have a separate support case for that.

Comment 4 Fedora Update System 2011-10-18 08:10:30 UTC
glibc-2.14.90-12.999 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2011-14504

Comment 5 Fedora Update System 2011-10-19 04:34:11 UTC
glibc-2.14.90-12.999 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.