Bug 737956 - php-extras from EPEL should require php-common inst. of php
Summary: php-extras from EPEL should require php-common inst. of php
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: php-extras
Version: el6
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Dmitry Butskoy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 13:34 UTC by Daniele Viganò
Modified: 2011-10-01 01:30 UTC (History)
2 users (show)

Fixed In Version: php-extras-5.3.3-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-01 01:30:47 UTC


Attachments (Terms of Use)
Modified SPEC file (8.79 KB, application/octet-stream)
2011-09-13 14:28 UTC, Daniele Viganò
no flags Details

Description Daniele Viganò 2011-09-13 13:34:22 UTC
Description of problem:

php-extras from EPEL (in ex. php-mcrypt) has 'php' in dependencies, so if you want to install it you are forced by yum to install whole Apache (httpd) also when you are using lighttpd or nginx.
php-extras should have 'php-common' as dependence instead of 'php', like in Fedora, so you don't need to install 'php' and 'httpd' if you have already 'php-cgi' installed with it's dependencies ('php-common').


Version-Release number of selected component (if applicable):

Name       : php-mcrypt
Arch       : x86_64
Version    : 5.3.2
Release    : 3.el6
Size       : 16 k
Repo       : epel


How reproducible:

yum install -y lighttpd lighttpd-fastcgi php-cgi
yum install php-mcrypt


Actual results:

================================================================================
 Package             Arch         Version                   Repository     Size
================================================================================
Installing:
 php-mcrypt          x86_64       5.3.2-3.el6               epel           16 k
Installing for dependencies:
 apr                 x86_64       1.3.9-3.el6_0.1           updates       124 k
 apr-util            x86_64       1.3.9-3.el6_0.1           updates        87 k
 apr-util-ldap       x86_64       1.3.9-3.el6_0.1           updates        15 k
 httpd               x86_64       2.2.15-5.el6.centos       base          811 k
 httpd-tools         x86_64       2.2.15-5.el6.centos       base           68 k
 libmcrypt           x86_64       2.5.8-9.el6               epel           96 k
 mailcap             noarch       2.1.31-1.1.el6            base           27 k
 php                 x86_64       5.3.2-6.el6_0.1           updates       1.1 M

Expected results:

================================================================================
 Package             Arch         Version                   Repository     Size
================================================================================
Installing:
 php-mcrypt          x86_64       5.3.2-3.el6               epel           16 k
Installing for dependencies:
 libmcrypt           x86_64       2.5.8-9.el6               epel           96 k

Comment 1 Daniele Viganò 2011-09-13 14:28:41 UTC
Created attachment 522937 [details]
Modified SPEC file

Comment 2 Fedora Update System 2011-09-13 14:38:02 UTC
php-extras-5.3.3-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/php-extras-5.3.3-1.el6

Comment 3 Dmitry Butskoy 2011-09-13 14:39:35 UTC
I prefer to use just "php-api = ..." dependency (which currently provided by php-common).

Comment 4 Daniele Viganò 2011-09-13 15:07:44 UTC
(In reply to comment #3)
> I prefer to use just "php-api = ..." dependency (which currently provided by
> php-common).

You're right, php-api should be sufficient and more correct.

Comment 5 Fedora Update System 2011-09-14 00:28:24 UTC
Package php-extras-5.3.3-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing php-extras-5.3.3-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/php-extras-5.3.3-1.el6
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-10-01 01:30:42 UTC
php-extras-5.3.3-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.