Bug 737996 - [as5] Unable to collect most of the metrics on the clustered web app contexts
Summary: [as5] Unable to collect most of the metrics on the clustered web app contexts
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Plugins
Version: 4.2
Hardware: Unspecified
OS: Unspecified
medium
unspecified vote
Target Milestone: ---
: ---
Assignee: Lukas Krejci
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 15:20 UTC by Lukas Krejci
Modified: 2012-02-07 19:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 738027 (view as bug list)
Environment:
Last Closed: 2012-02-07 19:22:46 UTC


Attachments (Terms of Use)
a clustering-ready WAR (907 bytes, application/x-webarchive)
2011-09-13 15:22 UTC, Lukas Krejci
no flags Details
Screenshot (132.98 KB, image/png)
2011-09-22 10:08 UTC, Sunil Kondkar
no flags Details


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPAPP-7172 Major Open Inconsistent naming of web application manager properties in JMX and ProfileService 2013-01-08 22:49:34 UTC

Description Lukas Krejci 2011-09-13 15:20:50 UTC
Description of problem:

When a web application is clustered, RHQ is unable to collect metrics like the number of active sessions.

This is due to an inconsistency in the property names returned from the AS's profile service that returns lowercase names when the web app context is not clustered (e.g. "activeSessions") but when it is clustered the property names start with an uppercase letter (e.g. "ActiveSessions").

This has been filed as a bug in the EAP:
https://issues.jboss.org/browse/JBPAPP-7172

However, RHQ should be robust enough to handle such differences.

Version-Release number of selected component (if applicable):
as5 plugin in all versions

How reproducible:
always

Steps to Reproduce:
1. Start JBoss AS 5 or up in the "all" profile (so that clustering is enabled)
2. Deploy the attached test WAR.
3. Wait for some metrics to be collected
  
Actual results:
Active Sessions and other metrics are never collected

Expected results:
All metrics are collected according to their schedules

Additional info:

Comment 1 Lukas Krejci 2011-09-13 15:22:22 UTC
Created attachment 522946 [details]
a clustering-ready WAR

Comment 2 Lukas Krejci 2011-09-13 16:44:23 UTC
commit 0c62a2411dbeddc5d67f30df71b7e8948225cf61
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Tue Sep 13 18:43:22 2011 +0200

    BZ 737996 - Working around the property names inconsistency in the clustered web app contexts.

Comment 3 Sunil Kondkar 2011-09-22 10:08:04 UTC
Verified on build#426 (Version: 4.1.0-SNAPSHOT Build Number: 7739090)

Started JBoss AS 5 with "all" profile and deployed the attached test WAR. Waited for some time and verified that the metrics like 'Currently Active Sessions' and other metrics are collected and displayed.

Please refer the attached screenshot.

Comment 4 Sunil Kondkar 2011-09-22 10:08:50 UTC
Created attachment 524375 [details]
Screenshot

Comment 5 Mike Foley 2012-02-07 19:22:46 UTC
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE


Note You need to log in before you can comment on or make changes to this bug.