Bug 738000 - NISDOMAIN key in /etc/sysconfig/network is not taken into account at boot
Summary: NISDOMAIN key in /etc/sysconfig/network is not taken into account at boot
Keywords:
Status: CLOSED DUPLICATE of bug 696629
Alias: None
Product: Fedora
Classification: Fedora
Component: ypbind
Version: 16
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Honza Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 15:35 UTC by Erwan ADAM
Modified: 2011-09-19 06:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-19 06:52:40 UTC


Attachments (Terms of Use)

Description Erwan ADAM 2011-09-13 15:35:54 UTC
Description of problem:

NISDOMAIN key in /etc/sysconfig/network is not taken into account at boot.
Thus ypbind is not started correctly neither than autofs.
Is this the normal behavior

Version-Release number of selected component (if applicable):

Fedora 16 alpha and Fedora 15

How reproducible:

always

Steps to Reproduce:

[root@is210376 ~]# cat /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=is210376
NISDOMAIN=foo.fr

re-boot

[root@is210376 ~]# nisdomainname 
nisdomainname: Local domain name not set

  
Actual results:


Expected results:

[root@is210376 ~]# nisdomainname 
foo.fr

Additional info:

The only workaround I found is to launch a script at the end of
boot in rc.local with :

...
nisdomainname foo.fr
service ypbind restart
service autofs restart
...

Ugly !

Thanks for your attention ! (First bug on bugzilla.redhat.com,
was on mandriva before ...)

Comment 1 Honza Horak 2011-09-15 14:05:10 UTC
I'm not able to reproduce this failure. Can you, please, tell me what version of ypbind you have? (simply run "rpm -q ypbind")

Comment 2 Erwan ADAM 2011-09-16 15:03:22 UTC
(Sorry for the delay. For other problems, I restarted on a fedora 15 updated.)

My ypbind version is
[adam@is210376 utils]$ rpm -q ypbind
ypbind-1.32-8.fc15.1.x86_64

Concerning the bug I encounter, first of all, I apologize
but I realized the ypbind service was not started at boot
but was appearing as "dead" (I'm not very familiar with
systemctl yet).

Well, after enabling ypbind.service at boot, the bug remains.
But it seems to be related to some other bugs in bugzilla
(for instance https://bugzilla.redhat.com/show_bug.cgi?id=696629).
It is like the network is not "fully" started when entering
startup of ypbind. It leads to "Host name lookup failure"
in /var/log/messages always followed by
"Lost connection to D-Bus" errors.

I solved my problems with the declaration of the ip address
of the nis server in the /etc/hosts file ... and now everything
works as expected (ypbind and autofs are ok).

I think this bug can be marked as duplicate of 696629 which
seems not solved for the moment.

Best regards,

          E.A.

Comment 3 Honza Horak 2011-09-19 06:52:40 UTC
Closing as a duplicate on reporter's suggestion.

*** This bug has been marked as a duplicate of bug 696629 ***


Note You need to log in before you can comment on or make changes to this bug.