Bug 738049 - [ipa webui] Remove Rule type info from HBAC page
Summary: [ipa webui] Remove Rule type info from HBAC page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Rob Crittenden
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks: 756082
TreeView+ depends on / blocked
 
Reported: 2011-09-13 18:11 UTC by Namita Soman
Modified: 2015-01-04 23:51 UTC (History)
6 users (show)

Fixed In Version: ipa-2.2.0-1.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Clone Of:
Environment:
Last Closed: 2012-06-20 13:14:07 UTC


Attachments (Terms of Use)
freeipa-edewata-0273-Removed-HBAC-rule-type.patch (1.69 KB, patch)
2011-09-27 18:27 UTC, Endi Sukma Dewata
no flags Details | Diff
ipa-HBAC-rule-type.patch (1.74 KB, patch)
2011-10-01 01:40 UTC, Endi Sukma Dewata
no flags Details | Diff
screen shot (55.00 KB, image/png)
2012-04-18 15:38 UTC, Jenny Severance
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0819 normal SHIPPED_LIVE ipa bug fix and enhancement update 2012-06-19 20:34:17 UTC

Description Namita Soman 2011-09-13 18:11:25 UTC
Description of problem:
HBAC page includes columns for Rule Type. Since we use only 'Allow" rules, this column is redundant, and can be removed for RHEL. 

There has been previous discussions about how to handle Deny rules since it got deprecated, and think upstream releases need to be handled differently. 

Version-Release number of selected component (if applicable):
ipa-server-2.1.1-1.el6.x86_64


How reproducible:
always

Steps to Reproduce:
1. Go to HBAC front page

  
Actual results:
The columns for Rule Type is available


Expected results:
Since the rule type is always 'allow', this column can be removed

Additional info:

Comment 2 Martin Kosek 2011-09-14 07:07:29 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/1795

Comment 3 Endi Sukma Dewata 2011-09-27 18:27:17 UTC
Created attachment 525185 [details]
freeipa-edewata-0273-Removed-HBAC-rule-type.patch

This patch should be included in the rpm spec for RHEL build since we decided not to push this patch into the ipa-2-1 branch upstream.

Comment 4 Endi Sukma Dewata 2011-10-01 01:40:40 UTC
Created attachment 525855 [details]
ipa-HBAC-rule-type.patch

This is a temporary patch that will work against the current 2.1.1 code. When the code is updated to 2.1.2 the patch should be replaced with freeipa-edewata-0273-Removed-HBAC-rule-type.patch.

Comment 6 Jenny Severance 2012-04-18 15:38:17 UTC
verified version ipa-server-2.1.3-9.el6.x86_64

see attached screenshot

Comment 7 Jenny Severance 2012-04-18 15:38:40 UTC
Created attachment 578397 [details]
screen shot

Comment 10 errata-xmlrpc 2012-06-20 13:14:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html


Note You need to log in before you can comment on or make changes to this bug.