Bug 738101 - Request for update to newer version with support for Audacious
Summary: Request for update to newer version with support for Audacious
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell-extension-mediaplayers
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-13 22:40 UTC by fropeter
Modified: 2012-02-25 17:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-25 17:22:42 UTC


Attachments (Terms of Use)

Description fropeter 2011-09-13 22:40:06 UTC
Description of problem:
Version 0.0.1, which is the current version in Fedora, does not support Audacious Media Player. The support was added to the git repo in mid-june. Is it possible to update the package to the newer code? (Also in F15?)

Version-Release number of selected component (if applicable):
Current in Fedora: 0.0.1
Can't find any version tags in the git repo.

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Fedora Update System 2011-10-01 10:45:27 UTC
gnome-shell-extension-mediaplayers-0-0.2.git1225d49.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnome-shell-extension-mediaplayers-0-0.2.git1225d49.fc15

Comment 2 Fedora Update System 2011-10-01 10:45:35 UTC
gnome-shell-extension-mediaplayers-0-0.2.git1225d49.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gnome-shell-extension-mediaplayers-0-0.2.git1225d49.fc16

Comment 3 fropeter 2011-10-01 15:09:04 UTC
Thanks for the update. I can't get it to work, though.

I installed this package through right-clicking and choosing 'Open with Software Install':
http://kojipkgs.fedoraproject.org/packages/gnome-shell-extension-mediaplayers/0/0.2.git1225d49.fc15/noarch/gnome-shell-extension-mediaplayers-0-0.2.git1225d49.fc15.noarch.rpm

When restarting the shell through Alt-F2/r, or logging out and logging in a Gnome session using any user, Gnome displays a message about something going wrong and only leaving the option to log out.

Logging in using LXDE allows me to inspect, and this is what I found:
The schema from the source package is not placed in the /usr/share/glib-2.0/schemas directory. I don't know if the schemas are compiled during the install, but with the schema missing and the files existing in /usr/share/gnome-shell/extensions, it triggers an error in Gnome when it tries to start.

After manually copying the schema to the /usr/share/glib-2.0/schemas directory and compiling them (sudo glib-compile-schemas /usr/share/glib-2.0/schemas), gnome works as before.

The mediaplayers extension is also showing up on the panel. But when trying to run the (sic) 'MediasPlayers Settings' i get the notification 
'Running mediasplayers-settings failed: Command not found'

I installed Banshee to see if the rest worked. (The extension complained about not finding Banshee when I tried some other control)
The other controls work as follows:
-  'Eject' button: Opens Banshee
-  No response from the other buttons, including the speaker icon (mute?)
-  Volum slider, shuffle switch and repeat switch operate, but have no effect.

As I don't know what of this relates to packaging or upstream, I leave that to you. If  you want me to send a bug report somewhere else, just let me know.

Comment 4 Fedora Update System 2011-10-01 18:45:27 UTC
Package gnome-shell-extension-mediaplayers-0-0.2.git1225d49.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-shell-extension-mediaplayers-0-0.2.git1225d49.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gnome-shell-extension-mediaplayers-0-0.2.git1225d49.fc16
then log in and leave karma (feedback).

Comment 5 fropeter 2011-10-06 17:25:59 UTC
Just wondering if the package has appeared in the testing repo yet; it's been 5 days...

yum doesn't find it.

Is this correct? (Equivalent to the su -c variant in comment 4
sudo yum update --enablerepo=updates-testing gnome-shell-extension-mediaplayers-0-0.2.git1225d49.fc16

Comment 6 Fabian Affolter 2011-11-10 08:31:49 UTC
Thanks for your testing.


Note You need to log in before you can comment on or make changes to this bug.