Bug 73815 - XFree86-devel need XCOMM after rebuild for i686.
XFree86-devel need XCOMM after rebuild for i686.
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
null
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-11 09:15 EDT by Knut J BJuland
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-11 13:31:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Knut J BJuland 2002-09-11 09:15:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020830

Description of problem:
When I rebuild XFree86 by using rpmbuild --rebuild --target=i686
XFree86-4.2.0-71.src.rpm, it say that is need XCOMM to install
XFree86-devel-4.2.0-71.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpmbuild --rebuild --target=i686 XFree86-4.2.0-71-src.rpm
2.rpm -Uvh /usr/src/redhat/RPMS/i686/XFree86*
3.
	

Actual Results:  XCOMM is need by XFree86-devel-4.2.0-71

Expected Results:  Xfree86 should be installed

Additional info:

gcc 2.96-RH
Comment 1 Mike A. Harris 2002-09-11 12:41:00 EDT
Several things to note...

1) 4.2.0-71 is broken.  Don't use it.  4.2.0-72 is the fixed
   proper release which should be used.

2) The 4.2.0-* packages build perfectly fine on Red Hat Linux 7.0, 7.1,
   7.2, 7.3 and rawhide, although older systems need to have some newer
   dependancies installed from newer releases.  Both gcc 2.96 and gcc 3.2
   will work.  My main development/build server builds X on Red Hat Linux
   7.0 with gcc-2.96-93 after which a successful build then gets built
   in the official Red Hat build system.

3) I have no idea what you're talking about some XCOMM error.  Please
   cut and paste the exact error in the bug report, or I can't begin
   to guess what the problem is you're experiencing.

4) Note that Red Hat does not support user recompiled software packages,
   and that includes packages rebuilt with different --target also.  That
   said, I personally try to keep things building and working across the
   board as best I can.  I'll do a test build right now for target=i686

Please provide a lot more detail, exact error output, and if possible
try to debug the issue to determine what the problem is.  If it is something
that is fixable and simple, I don't mind doing so.  If it is a random
fluke due to you recompiling it with gcc 2.96 on an older system though
and I can't reproduce it, then I can't likely do anything about it.
Comment 2 Knut J BJuland 2002-09-11 13:06:06 EDT
I have gcc-2.96-112, the rest is standard 7.3.
Comment 3 Mike A. Harris 2002-09-11 13:16:46 EDT
3) I have no idea what you're talking about some XCOMM error.  Please
   cut and paste the exact error in the bug report, or I can't begin
   to guess what the problem is you're experiencing.

Please provide a lot more detail, exact error output, and if possible
try to debug the issue to determine what the problem is.


Comment 4 Knut J BJuland 2002-09-11 13:31:24 EDT
error: failed dependencies:
	XCOMM   is needed by XFree86-devel-4.2.0-71
Comment 5 Mike A. Harris 2002-09-15 20:37:42 EDT
There's no such thing as XCOMM, so I have no idea what you are
reporting.  I've asked for a lot of detail and received very little
back.

I'm able to build XFree86 on every release of Red Hat Linux from
7.0 upward, and I'm also able to rebuild the package targetted
for i686 without any problems.

Unreproduceable, closing WORKSFORME

Note You need to log in before you can comment on or make changes to this bug.