Bug 738170 - Transfer vmcore file fail in kdump kernel with rhevm bridge
Summary: Transfer vmcore file fail in kdump kernel with rhevm bridge
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 6.2
Assignee: Alan Pevec
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-14 08:56 UTC by cshao
Modified: 2016-04-26 13:41 UTC (History)
7 users (show)

Fixed In Version: ovirt-node-2.0.2-0.14.gitb764606.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 19:27:43 UTC


Attachments (Terms of Use)
kdump.txt (7.52 KB, text/plain)
2011-09-14 08:56 UTC, cshao
no flags Details
ovirt.log (11.04 KB, text/plain)
2011-09-14 08:57 UTC, cshao
no flags Details
quickfix in rhevh ks (1.23 KB, patch)
2011-11-01 05:01 UTC, Alan Pevec
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1783 normal SHIPPED_LIVE rhev-hypervisor6 bug fix and enhancement update 2011-12-06 15:10:54 UTC

Description cshao 2011-09-14 08:56:59 UTC
Created attachment 523087 [details]
kdump.txt

Description of problem:
Kdump fail in get DHCP address after register RHEV-H to RHEV-M.

Version-Release number of selected component (if applicable):
rhev-hypervisor-6.2-0.16.2.el6

How reproducible:
100%

Steps to Reproduce:
1. Register RHEV-H to RHEV-M.
2. Enter kdump menu, setting kdump to SSH or NFS.
3. Execute command " echo "c" > /proc/sysrq-trigger".
  
Actual results:
Kdump fail in get DHCP address.
Select kdump to Restore(local) can successful.


Please see serial console log
=====================================================

mapping rhevm to lo
udhcpc (v1.15.1) started
Sending discover...
Sending discover...
Sending discover...
Unable to get a DHCP address retry...
No lease, failing
lo failed to come up
Restarting system.

brctl show
=====================================================
# brctl show
bridge name	bridge id		STP enabled	interfaces
rhevm		8000.f04da224d2ea	no		eth0

ifcfg-eth0 & ifcfg-rhevm
=====================================================
[root@localhost network-scripts]# cat ifcfg-eth0
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=none
HWADDR=F0:4D:A2:24:D2:EA
BRIDGE=rhevm

[root@localhost network-scripts]# cat ifcfg-rhevm 
DEVICE=rhevm
TYPE=Bridge
ONBOOT=yes
DELAY=0
IPV6FORWARDING=no
IPV6INIT=no
DELAY=0
BOOTPROTO=dhcp
IPV6_AUTOCONF=no
PEERNTP=yes
ONBOOT=yes

kdump.conf
=====================================================
[root@localhost network-scripts]# cat /etc/kdump.conf 
default reboot
net 10.66.65.100:/home/vol/cshao/data


Expected results:
Kdump to NFS / SSH can successful after register RHEV-H to RHEV-M.

Additional info:

Comment 1 cshao 2011-09-14 08:57:47 UTC
Created attachment 523089 [details]
ovirt.log

Comment 2 Alan Pevec 2011-09-14 09:05:11 UTC
Does DHCP in kexec work before RHEV-M registration?
Please provide serial console log for that case.

> mapping rhevm to lo

This is where it goes wrong, but no idea yet why is that.

Comment 8 Alan Pevec 2011-10-31 21:09:10 UTC
kdump initrd embeds current network configuration at the time it was created,
service kdump restart needs to be triggered after network configuration changes.

Comment 9 Alan Pevec 2011-11-01 04:45:44 UTC
Not only that, but mkdumprd has assumption that brige name starts with br*
Quick fix for patching in rhevh kickstart:
--- /sbin/mkdumprd.ORIG	2011-10-06 06:37:49.000000000 +0000
+++ /sbin/mkdumprd	2011-11-01 04:21:19.000000000 +0000
@@ -583,7 +583,7 @@
         eth*.*)
             modalias=8021q
             ;;
-        br*)
+        rhevm|br*)
             modalias=bridge
             ;;
         *)
@@ -756,7 +756,7 @@
             echo >> $MNTIMAGE/etc/ifcfg-$dev
             echo "BUS_ID=\"Bonding\"" >> $MNTIMAGE/etc/ifcfg-$dev
             ;;
-	br*)
+	rhevm|br*)
             for j in `ls /sys/class/net/$dev/brif`
             do
                 handlenetdev $j

Comment 10 Alan Pevec 2011-11-01 05:01:56 UTC
Created attachment 531065 [details]
quickfix in rhevh ks

Comment 13 errata-xmlrpc 2011-12-06 19:27:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html


Note You need to log in before you can comment on or make changes to this bug.