Bug 738256 - redhat-lsb fails to build on ARM
Summary: redhat-lsb fails to build on ARM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-lsb
Version: rawhide
Hardware: arm9
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Parag Nemade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-14 12:17 UTC by Gordan Bobic
Modified: 2012-01-31 17:27 UTC (History)
6 users (show)

Fixed In Version: redhat-lsb-4.0-6.1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-13 21:55:25 UTC


Attachments (Terms of Use)
redhat-lsb ARM patch from 3.x (1.52 KB, patch)
2011-09-14 12:18 UTC, Gordan Bobic
no flags Details | Diff
Fixed and improved redhat-lsb-trigger.patch (2.99 KB, patch)
2011-09-14 12:18 UTC, Gordan Bobic
no flags Details | Diff
redhat-lsb fixed to build on arm (49.92 KB, application/octet-stream)
2011-10-12 15:09 UTC, Gordan Bobic
no flags Details

Description Gordan Bobic 2011-09-14 12:17:25 UTC
Description of problem:
redhat-lsb fails to build on arm. Additional patches are required.

Version-Release number of selected component (if applicable):
4.0-3

The ARM patch from redhat-lsb 3.x is still required, and a suitably modified version is attached.

This is not sufficient, however, and the build will still fail due to duplicate definitions of:
__libc_start_main
__libc_csu_init
__libc_csu_fini

This is partially due to broken assumptions made by the
redhat-lsb-trigger.patch for PPC the package ships with. A fixed and expanded version of redhat-lsb-trigger.patch is also attached.

With these two changes, redhat-lsb src.rpm will build.

Comment 1 Gordan Bobic 2011-09-14 12:18:15 UTC
Created attachment 523137 [details]
redhat-lsb ARM patch from 3.x

Comment 2 Gordan Bobic 2011-09-14 12:18:54 UTC
Created attachment 523138 [details]
Fixed and improved redhat-lsb-trigger.patch

Comment 3 Parag Nemade 2011-10-12 12:10:24 UTC
Please provide additional information like

1) which package against you reported bug
2) how to scratch build for fixed srpm?
3) Is f16 available target for arm?

I tried to  build f16 srpm on arm but it failed 
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=183982

Comment 4 Gordan Bobic 2011-10-12 15:09:18 UTC
Created attachment 527726 [details]
redhat-lsb fixed to build on arm

The patches I attached previously were against 4.0-3. I have now attached the complete src.rpm with required patches.

Comment 5 Parag Nemade 2011-10-13 06:54:26 UTC
Still I am not sure where to commit this change. Latest build for rawhide is now redhat-lsb-4.0-8.fc17

you are reporting against 4.0-3 release and current release is 4.0-8

how can one build for arm9?

Comment 6 Gordan Bobic 2011-10-13 09:07:25 UTC
Do the patches I attached apply cleanly against 4.0-8?

You may have to adjust the ExclusiveArch list in the spec file to include %{arm}, the koji error implies that arm variants aren't included in the package.

You should be able to build it with
rpmbuild --target=armv5tel
if you have an arm machine.

If you are concerned about the report being against "arm9" instead of "armv5tel", see here:
https://bugzilla.redhat.com/show_bug.cgi?id=666284

Comment 7 Parag Nemade 2011-10-13 09:53:59 UTC
Ok after I did various scratch builds I come to conclusion that latest f14 build is possible. See
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=184312

But no further releases build working
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=184310

Hmm. So overall it looks I need to commit in f14 branch. so no need to apply same patch in f15 and above?

Comment 8 Gordan Bobic 2011-10-13 10:45:03 UTC
ARM port hasn't caught up with primaries yet. The latest release is F13. F14 still has a few packages missing, and F15 is further behind than that, plus, F15 is where hard-float is being introduced. That is probably why koji is saying there is no working mock buildroot for F15+.

Comment 9 D. Marlin 2011-11-29 23:14:33 UTC
The patched package now successfully builds for fc15.armv7hl.

A scratch build can be found at:

  http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=214444

Can the patches now be committed to F15+ branches as well?

Comment 10 Parag Nemade 2011-11-30 13:27:17 UTC
Okay committed for F15 and above. Do you need fix for older releases also but I guess old release f14 is going to EOL on 8th Dec.

Comment 11 Fedora Update System 2011-11-30 13:44:06 UTC
redhat-lsb-4.0-6.1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/redhat-lsb-4.0-6.1.fc15

Comment 12 Fedora Update System 2011-11-30 13:44:14 UTC
redhat-lsb-4.0-7.1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/redhat-lsb-4.0-7.1.fc16

Comment 13 D. Marlin 2011-11-30 14:00:49 UTC
(In reply to comment #10)
> Okay committed for F15 and above. Do you need fix for older releases also but I
> guess old release f14 is going to EOL on 8th Dec.

We are only interested in F15 and newer, so using F14 as the 'old release' works for us.

Thank you.

Comment 14 Fedora Update System 2011-12-02 21:27:37 UTC
Package redhat-lsb-4.0-6.1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing redhat-lsb-4.0-6.1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16632/redhat-lsb-4.0-6.1.fc15
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2011-12-13 21:55:25 UTC
redhat-lsb-4.0-7.1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2011-12-21 17:09:53 UTC
redhat-lsb-4.0-6.1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 jiri vanek 2012-01-30 13:29:39 UTC
Fedora 17 arm koji build is reporting:
Getting requirements for 1:java-1.6.0-openjdk-1.6.0.0-64.1.11pre.fc17.src
...
Error: No Package found for redhat-lsb

Comment 18 Parag Nemade 2012-01-31 04:27:29 UTC
I do not work on ARM project and building for ARM is not allowed to me.

Comment 19 Parag Nemade 2012-01-31 04:42:30 UTC
Jiri,
   I am not getting any help on building package for ARM. Looks some policy violation issue.

Comment 20 D. Marlin 2012-01-31 16:42:08 UTC
I can submit builds for ARM, and will help in any way I can.

Please let me know what we need to do on this.

Comment 21 D. Marlin 2012-01-31 17:27:38 UTC
note: It appears that redhat-lsb-4.0-11 successfully built for f17:

  http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=49642


Note You need to log in before you can comment on or make changes to this bug.