Bug 738354 - Sending message with a subject to a queue fails
Summary: Sending message with a subject to a queue fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-java
Version: 2.0
Hardware: All
OS: All
medium
high
Target Milestone: 2.0.3
: ---
Assignee: messaging-bugs
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On: 726712
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-14 15:33 UTC by Justin Ross
Modified: 2011-09-28 15:53 UTC (History)
6 users (show)

Fixed In Version: qpid-java-0.10-9
Doc Type: Bug Fix
Doc Text:
Clone Of: 726712
Environment:
Last Closed: 2011-09-28 15:53:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1340 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 2.0.3 bug fix update 2011-09-28 15:53:05 UTC

Description Justin Ross 2011-09-14 15:33:40 UTC
+++ This bug was initially created as a clone of Bug #726712 +++

Created attachment 515896 [details]
patch proposal (its description in JIRA 3377)

Description of problem:
Having a queue bound just to default exchange and sending a message with a subject to the queue results in dropping the message by the default queue.


Version-Release number of selected component (if applicable):
any


How reproducible:
100%


Steps to Reproduce:
1) qpid-config add queue testQueue
2) cd /usr/share/doc/qpid-java-0.10/examples
3) ./run_example.sh org.apache.qpid.example.Spout testQueue/someSubject

  
Actual results:
qpid-stat -e shows the default '' exchange dropped the message


Expected results:
The message (with subject "someSubject") should be routed to "testQueue" queue.

Additional info:
See JIRA 3377 for the same (https://issues.apache.org/jira/browse/QPID-3377)
Patch already proposed.

--- Additional comment from pmoravec@redhat.com on 2011-08-04 02:58:45 EDT ---

Rajith posted a patch to upstream (see the JIRA updates).

--- Additional comment from rattapat@redhat.com on 2011-08-30 14:43:33 EDT ---

This is tracked in upstream via https://issues.apache.org/jira/browse/QPID-3377

Applied patch from Pavel in upstream along with a test case. Details as follows,
http://svn.apache.org/viewvc?view=rev&rev=1153298

test case,
http://svn.apache.org/viewvc?view=rev&rev=1153299

--- Additional comment from rattapat@redhat.com on 2011-08-30 15:05:36 EDT ---

If back porting the above fix, the the following commit also needs to be ported in order for 1153298 to compile properly.
http://svn.apache.org/viewvc?view=rev&rev=1153272

--- Additional comment from zkraus@redhat.com on 2011-09-14 08:02:42 EDT ---

Fix was tested on:
RHEL 5.7 x86/x64
qpid-java-common-0.10-9.el5
qpid-java-client-0.10-9.el5
qpid-java-jca-0.10-9.el5
qpid-java-example-0.10-9.el5

RHEL 6.1 x86/x64
qpid-java-jca-0.10-9.el6.noarch
qpid-java-common-0.10-9.el6.noarch
qpid-java-example-0.10-9.el6.noarch
qpid-java-client-0.10-9.el6.noarch

changing to VERIFIED

Comment 1 errata-xmlrpc 2011-09-28 15:53:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1340.html


Note You need to log in before you can comment on or make changes to this bug.