Bug 738371 - ERROR with rpm_check_debug vs depsolve:
Summary: ERROR with rpm_check_debug vs depsolve:
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssh
Version: 4.9
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: 4.9
Assignee: Petr Lautrbach
QA Contact: BaseOS QE Security Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-14 15:59 UTC by Phillip T Dennis
Modified: 2012-03-05 14:28 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-05 14:28:57 UTC


Attachments (Terms of Use)

Description Phillip T Dennis 2011-09-14 15:59:20 UTC
Description of problem:
update error

Version-Release number of selected component (if applicable):


How reproducible:
yum install trackingpkg
  
Actual results:
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
openssh is needed by (installed) openssh-askpass-3.9p1-11.el4_8.1.x86_64
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])

Expected results:
We install a tracking package twice a year to help us report on a yearly server patch status


Additional info:

Comment 1 Phillip T Dennis 2011-09-14 20:46:54 UTC
I fixed the dependency issue on one server by running a yum update openssh-askpass-3.9p1-11.el4_8.1.x86_64

I was then able install our tracking package.

===

I still have a tracking package issue with a RHEL 4 32-bit vm host. I am still trying to figure out why I am having so many issues with openssh/ssl.

Details below
===
[root@pvmk7796 ~]# rpm -qa | grep op
popt-1.9.1-26_nonptl
opensm-libs-3.1.8-1.el4
openssh-3.9p1-11.el4_7
openssl-0.9.7a-43.17.el4_7.2
desktop-file-utils-0.9-3.el4
xmlsec1-openssl-1.2.6-3
openssh-clients-3.9p1-11.el4_7
openssh-server-3.9p1-11.el4_7
openssh-askpass-3.9p1-11.el4_7
openldap-clients-2.2.13-12.el4
openssl096b-0.9.6b-22.46.el4_7
openldap-2.2.13-12.el4
openmotif21-2.1.30-11.RHEL4.6
popt-1.9.1-33_nonptl.el4_8.1
opensm-libs-3.2.5-1.el4
openssl096b-0.9.6b-22.46.el4_8.1
openssh-askpass-3.9p1-11.el4_8.1


--> Populating transaction set with selected packages. Please wait.
---> Package trackingpkg.noarch 0:4AS-11H2 set to be updated
--> Running transaction check
--> Processing Dependency: redhat-release >= 4AS-10.1 for package: trackingpkg
--> Processing Dependency: opsware-agent >= 40.0.0.1.88.linux.linux.4AS-Sprint_1 for package: trackingpkg
--> Processing Dependency: ntp >= 4.2.0.a.20040617-12.el4 for package: trackingpkg
--> Processing Dependency: ewatd >= 1.9.4-9 for package: trackingpkg
--> Processing Dependency: openssl >= 0.9.7a-43.17.el4_8.6 for package: trackingpkg
--> Processing Dependency: tzdata >= 2011g-1.el4 for package: trackingpkg
--> Processing Dependency: openssh >= 3.9p1-11.el4_8.1 for package: trackingpkg
--> Processing Dependency: sysklogd >= 1.4.1-30.el4 for package: trackingpkg
--> Processing Dependency: pam >= 0.77-66.26.el4_8.2 for package: trackingpkg
--> Processing Dependency: lvm2 >= 2.02.42-9.el4 for package: trackingpkg
--> Processing Dependency: bash >= 3.0-27.el4 for package: trackingpkg
--> Processing Dependency: glibc >= 2.3.4-2.54 for package: trackingpkg
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package ewatd.noarch 0:1.9.4-9 set to be updated
---> Package redhat-release.i386 0:4AS-10.1 set to be updated
---> Package openssh.i386 0:3.9p1-11.el4_8.1 set to be updated
---> Package openssl.i686 0:0.9.7a-43.17.el4_8.6 set to be updated
---> Package tzdata.noarch 0:2011g-1.el4 set to be updated
---> Package pam.i386 0:0.77-66.26.el4_8.2 set to be updated
---> Package glibc.i686 0:2.3.4-2.54 set to be updated
---> Package sysklogd.i386 0:1.4.1-30.el4 set to be updated
---> Package opsware-agent.i386 0:40.0.0.1.88.linux.linux.4AS-Sprint_1 set to be updated
---> Package bash.i386 0:3.0-27.el4 set to be updated
---> Package ntp.i386 0:4.2.0.a.20040617-12.el4 set to be updated
---> Package lvm2.i386 0:2.02.42-9.el4 set to be updated
--> Running transaction check
--> Processing Dependency: glibc-common = 2.3.4-2.54 for package: glibc
--> Processing Dependency: glibc = 2.3.4-2.43 for package: glibc-devel
--> Processing Dependency: glibc = 2.3.4-2.43.el4_8.6 for package: glibc-devel
--> Processing Dependency: glibc = 2.3.4-2.43 for package: glibc-headers
--> Processing Dependency: openssh = 3.9p1-11.el4_7 for package: openssh-askpass
--> Processing Dependency: glibc = 2.3.4-2.43.el4_8.6 for package: glibc-headers
--> Processing Dependency: openssh = 3.9p1-11.el4_7 for package: openssh-clients
--> Processing Dependency: device-mapper >= 1.02.28-3 for package: lvm2
--> Processing Dependency: openssh = 3.9p1-11.el4_7 for package: openssh-server
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package glibc-headers.i386 0:2.3.4-2.54 set to be updated
---> Package glibc-common.i386 0:2.3.4-2.54 set to be updated
---> Package device-mapper.i386 0:1.02.28-3.el4 set to be updated
---> Package openssh-clients.i386 0:3.9p1-11.el4_8.1 set to be updated
---> Package glibc-devel.i386 0:2.3.4-2.54 set to be updated
---> Package openssh-server.i386 0:3.9p1-11.el4_8.1 set to be updated
--> Running transaction check
--> Processing Dependency: openssh = 3.9p1-11.el4_7 for package: openssh-askpass
--> Finished Dependency Resolution
Error: Missing Dependency: openssh = 3.9p1-11.el4_7 is needed by package openssh-askpass


Error: Missing Dependency: openssh = 3.9p1-11.el4_7 is needed by package openssh-askpass
Error: Missing Dependency: ibutils = 1.2-3.el4 is needed by package ibutils-libs

Comment 2 Petr Lautrbach 2012-03-05 14:28:57 UTC
Red Hat Enterprise Linux 4 is no longer supported.


Note You need to log in before you can comment on or make changes to this bug.