Bug 738588 - 'qpid-config --passive' help
Summary: 'qpid-config --passive' help
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-tools
Version: 2.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Darryl L. Pierce
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-15 10:00 UTC by Stanislav Graf
Modified: 2015-06-22 00:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-22 21:41:32 UTC


Attachments (Terms of Use)

Description Stanislav Graf 2011-09-15 10:00:24 UTC
Description of problem:
When asking for help for 'qpid-config --passive' we get:
[root@rhel6i ~]$ qpid-config --help | grep -A 3 passive
    --passive, --dry-run
                        Do not actually add the exchange or queue, ensure that
                        all parameters and permissions are correct and would
                        allow it to be created.


Actually it should report statement from this PDF instead:
http://www.amqp.org/confluence/download/attachments/720900/amqp.0-10.pdf
'If set, the server will not create the exchange. The client can use this to check whether an exchange
exists without modifying the server state.'

Because this is what this command does:
Does the queue qname_test exists?
[root@rhel6i ~]$ qpid-config add queue qname_test --durable --passive
Failed: SessionException: ExecutionException(error_code=404, command_id=serial(81), class_code=8, command_code=1, field_index=0, description=u'not-found: Queue not found: qname_test (qpid/broker/SessionAdapter.cpp:686)', error_info={}, channel=1, id=serial(93))
ecode=1

No queue qname_test doesn't exist. So create queue:
[root@rhel6i ~]$ qpid-config add queue qname_test --durable
ecode=0

Does the queue qname_test exist now? 
[root@rhel6i ~]$ qpid-config add queue qname_test --durable --passive
ecode=0

Yes queue exist.

Version-Release number of selected component (if applicable):
qpid-tools-0.10-5.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. qpid-config --help | grep -A 3 passive
2. qpid-config add queue qname_test --durable --passive
3. qpid-config add queue qname_test --durable
4. qpid-config add queue qname_test --durable --passive
  
Actual results:
[root@rhel6i ~]$ qpid-config --help | grep -A 3 passive
    --passive, --dry-run
                        Do not actually add the exchange or queue, ensure that
                        all parameters and permissions are correct and would
                        allow it to be created.

Expected results:
[root@rhel6i ~]$ qpid-config --help | grep -A 3 passive
    --passive, --dry-run
                        If set, the server will not create the exchange. 
			The client can use this to check whether an exchange
			exists without modifying the server state.

Additional info:

Comment 2 Darryl L. Pierce 2012-04-23 17:45:03 UTC
In looking through the qpid-tool, it seems the --passive command option was removed after 0.14.

Comment 3 Leonid Zhaldybin 2013-02-07 11:27:39 UTC
(In reply to comment #2)
> In looking through the qpid-tool, it seems the --passive command option was
> removed after 0.14.

Confirming, the 0.18 (MRG/M 2.3) version of qpid-config tool will not have this option. I think this bug should be closed.


Note You need to log in before you can comment on or make changes to this bug.