Bug 738620 - PID file of cgred is not labelled correctly
Summary: PID file of cgred is not labelled correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libcgroup
Version: 6.2
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Peter Schiffer
QA Contact: Petr Beňas
URL:
Whiteboard:
Depends On:
Blocks: 767187
TreeView+ depends on / blocked
 
Reported: 2011-09-15 11:59 UTC by Milos Malik
Modified: 2015-01-04 23:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Clone Of:
Environment:
Last Closed: 2013-11-21 22:31:15 UTC


Attachments (Terms of Use)
libcgroup-0.40.rc1-restorecon.patch (429 bytes, patch)
2013-08-27 18:25 UTC, Peter Schiffer
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1685 normal SHIPPED_LIVE libcgroup bug fix and enhancement update 2013-11-20 21:52:29 UTC

Description Milos Malik 2011-09-15 11:59:57 UTC
Description of problem:
I believe that following line is missing in /etc/init.d/cgred:
[ -x /sbin/restorecon ] && /sbin/restorecon $pidfile

Version-Release number of selected component (if applicable):
libcgroup-0.37-3.el6

How reproducible:
always

Steps to Reproduce:
# restorecon -Rv /etc /var
# service cgconfig status
Running
# service cgred stop
Stopping CGroup Rules Engine Daemon...                     [  OK  ]
# service cgred start
Starting CGroup Rules Engine Daemon:                       [  OK  ]
# restorecon -Rv /etc /var
restorecon reset /var/run/cgred.pid context unconfined_u:object_r:initrc_var_run_t:s0->system_u:object_r:cgred_var_run_t:s0
# 

Actual results:
* PID file is not labelled correctly

Expected results:
* PID file is labelled correctly

Comment 1 RHEL Product and Program Management 2011-09-15 12:08:12 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Suzanne Yeghiayan 2012-02-14 23:15:59 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 4 RHEL Product and Program Management 2012-07-10 08:09:54 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 5 RHEL Product and Program Management 2012-07-11 00:00:28 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 6 RHEL Product and Program Management 2012-12-14 08:09:13 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 7 Peter Schiffer 2013-08-27 18:25:34 UTC
Created attachment 791143 [details]
libcgroup-0.40.rc1-restorecon.patch

Comment 11 Petr Beňas 2013-09-11 13:51:43 UTC
Reproduced in libcgroup-0.40.rc1-1.el6.x86_64 and verified in libcgroup-0.40.rc1-2.el6.x86_64.

Comment 12 errata-xmlrpc 2013-11-21 22:31:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1685.html


Note You need to log in before you can comment on or make changes to this bug.