Bug 738702 - Librdmacm-1.0.15 needed in RHEL6.2
Summary: Librdmacm-1.0.15 needed in RHEL6.2
Keywords:
Status: CLOSED DUPLICATE of bug 696019
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: librdmacm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Doug Ledford
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-15 15:06 UTC by Steve Wise
Modified: 2011-09-20 22:26 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-20 22:26:44 UTC


Attachments (Terms of Use)

Description Steve Wise 2011-09-15 15:06:47 UTC
I believe this commit is in RHEL6.2:

commit b955150ea784af4c193b708a2e8091673bf23004
Author: Steve Wise <swise@opengridcomputing.com>
Date:   Thu Oct 21 12:37:06 2010 +0000

    RDMA/cxgb3: When a user QP is marked in error, also mark the CQs in error


It exposes 2 existing bugs in rping which is packaged with librdmacm.  The fixes are upstream.  We need to pull in librdmacm-1.0.15 in order to fix the rping issue.  

Or, if you maintain your own fixes, the commits are:

commit 93635fa33b41d356fa096242fec4ce788194b42f
Author: Sean Hefty <sean.hefty@intel.com>
Date:   Mon Nov 1 11:12:13 2010 -0700

    librdmacm/rping: Make sure CQ event thread exits before destroying the CQ

commit 8c6aeb3e70bbf275f9b618775133b9ae6f07ad15
Author: Steve Wise <swise@opengridcomputing.com>
Date:   Wed Oct 20 12:34:55 2010 -0700

    RPING: Remove printf for FLUSH completion.


The failure mode for the first bug above is a seg fault.  The 2nd bug is just a
warning printf that should be removed.

Comment 2 Doug Ledford 2011-09-20 22:26:44 UTC
1.0.15 includes XRC support.  That's too invasive for this late in the game.  So, instead I'm going to mark this bug a dup of the bug I already have for the rping issue.

*** This bug has been marked as a duplicate of bug 696019 ***


Note You need to log in before you can comment on or make changes to this bug.