Bug 738825 - Provide compatibility for php53 or 3rd party php-5.3+ rpms
Summary: Provide compatibility for php53 or 3rd party php-5.3+ rpms
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: phpMyAdmin3
Version: el5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-15 22:00 UTC by Greg Swallow
Modified: 2011-09-16 08:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-15 22:09:53 UTC


Attachments (Terms of Use)

Description Greg Swallow 2011-09-15 22:00:14 UTC
Just throwing out an idea to be able to provide a phpmyadmin rpm for EPEL5 that is also compatible with upgraded php-5.3, or someday php-5.4 rpms from famillecollet.com, or some other popular repositories that are used with EPEL.  I made a similar suggestion for the drupal7 rpm - see https://bugzilla.redhat.com/show_bug.cgi?id=738105#c2 for more info.  I haven't tested it yet, but I think it might work

Comment 1 Robert Scheck 2011-09-15 22:09:53 UTC
phpMyAdmin3 for EPEL 5 has already working dependencies for PHP 5.3. I am not
willing to support any RPM package that is not in RHEL and/or EPEL.

Comment 2 Greg Swallow 2011-09-15 22:45:52 UTC
Maybe someone else is then?  I think you could at least say re-open if you have a patch that works for both people that use RHEL/EPEL only and others that use php rpms from famillecollet.com.  Remi just announced 10+million rpm downloads from his servers alone...I would not be surprised if there are more servers running his php rpms than the php53 rpms in RHEL.

http://fedoraproject.org/wiki/EPEL/FAQ#Is_EPEL_willing_to_cooperate_with_other_third_party_repositories.3F

Comment 3 Robert Scheck 2011-09-15 23:14:03 UTC
Ask Red Hat to fix their broken packaging at the php53 packages, then I will
switch the RPM package dependency to what it normally should be. Otherwise it
will remain as it is. Please help to get rid of the cause, not of the impact.
I also do not want to see such a strange workaround applied by somebody else
to my packages...

Comment 4 Greg Swallow 2011-09-16 08:19:51 UTC
I have no say in what Redhat does...They would have to put the php53 rpms in a separate channel to have the proper provides set, or else php would update on every server.  I don't think that will happen.  Just think, if they had released php53 in a separate channel to begin with, they wouldn't have had to rename it php53...Oh well.

Comment 5 Robert Scheck 2011-09-16 08:56:07 UTC
If you have a Red Hat subscription, open a ticket and bother them simply.


Note You need to log in before you can comment on or make changes to this bug.