Bug 738940 - sosreport path to lvm commands incorrect
Summary: sosreport path to lvm commands incorrect
Keywords:
Status: CLOSED DUPLICATE of bug 704383
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sos
Version: 6.1
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Bryn M. Reeves
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-16 04:40 UTC by Trapier Marshall
Modified: 2013-09-30 01:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-21 15:19:34 UTC


Attachments (Terms of Use)

Description Trapier Marshall 2011-09-16 04:40:45 UTC
Description of problem:
sosreport does not collect the ouput from lvm commands.  The paths to the lvm commands in /usr/lib/python2.6/site-packages/sos/plugins/devicemapper.py are incorrect.  Between RHEL 5 and RHEL 6 these commands have moved from /usr/sbin to /sbin.

     37         self.collectExtOutput("/usr/sbin/vgdisplay -vv", root_symlink = "vgdisplay")
     38         self.collectExtOutput("/usr/sbin/vgscan -vvv")
     39         self.collectExtOutput("/usr/sbin/pvscan -v")
     40         self.collectExtOutput("/usr/sbin/lvs -a -o +devices")
     41         self.collectExtOutput("/usr/sbin/pvs -a -v")
     42         self.collectExtOutput("/usr/sbin/vgs -v")

Should be:

     37         self.collectExtOutput("/sbin/vgdisplay -vv", root_symlink = "vgdisplay")
     38         self.collectExtOutput("/sbin/vgscan -vvv")
     39         self.collectExtOutput("/sbin/pvscan -v")
     40         self.collectExtOutput("/sbin/lvs -a -o +devices")
     41         self.collectExtOutput("/sbin/pvs -a -v")
     42         self.collectExtOutput("/sbin/vgs -v")

Version-Release number of selected component (if applicable):
sos-2.2-8.el6.noarch

How reproducible:
100% of the time sosreport is run.

Steps to Reproduce:
Run sosreport:

# sosreport

  
Actual results:
$ find sos_commands/devicemapper/
sos_commands/devicemapper/
sos_commands/devicemapper/dmraid_-r
sos_commands/devicemapper/dmraid_-s
sos_commands/devicemapper/dmraid_-tay
sos_commands/devicemapper/dmraid_-b
sos_commands/devicemapper/ls_-laR_.dev
sos_commands/devicemapper/dmraid_-rD
sos_commands/devicemapper/mdadm_-D_.dev.md
sos_commands/devicemapper/dmsetup_table
sos_commands/devicemapper/dmsetup_ls_--tree
sos_commands/devicemapper/dmsetup_status
sos_commands/devicemapper/dmraid_-V
sos_commands/devicemapper/ls_-laR_.sys.block
sos_commands/devicemapper/dmsetup_info_-c

Expected results:
$ find sos_commands/devicemapper/
sos_commands/devicemapper/
sos_commands/devicemapper/vgs_-v
sos_commands/devicemapper/dmsetup_status
sos_commands/devicemapper/dmraid_-r
sos_commands/devicemapper/vgscan_-vvv
sos_commands/devicemapper/dmsetup_table
sos_commands/devicemapper/pvs_-a_-v
sos_commands/devicemapper/lvs_-a_-o_devices
sos_commands/devicemapper/dmraid_-rD
sos_commands/devicemapper/mdadm_-D_.dev.md
sos_commands/devicemapper/vgdisplay_-vv
sos_commands/devicemapper/dmraid_-tay
sos_commands/devicemapper/dmraid_-V
sos_commands/devicemapper/dmsetup_info_-c
sos_commands/devicemapper/pvscan_-v
sos_commands/devicemapper/dmraid_-b
sos_commands/devicemapper/dmraid_-s
sos_commands/devicemapper/ls_-laR_.sys.block
sos_commands/devicemapper/ls_-laR_.dev
sos_commands/devicemapper/dmsetup_ls_--tree

Comment 2 Bryn M. Reeves 2011-09-21 15:19:34 UTC

*** This bug has been marked as a duplicate of bug 704383 ***


Note You need to log in before you can comment on or make changes to this bug.