Bug 738942 - [virt-manager] CDROM Boot option will be enabled when install guest from boot.iso
Summary: [virt-manager] CDROM Boot option will be enabled when install guest from boot...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.2
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-16 05:06 UTC by Daisy Wu
Modified: 2011-10-17 02:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-17 02:24:51 UTC


Attachments (Terms of Use)

Description Daisy Wu 2011-09-16 05:06:40 UTC
Description of problem:
CDROM Boot option will be enabled when install guest from boot.iso

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-6.el6
libvirt-0.9.4-9.el6
python-virtinst-0.600.0-3.el6
qemu-kvm-0.12.1.2-2.184.el6.x86_64

#uname -a
Linux wjx.nay.redhat.com 2.6.32-191.el6.x86_64 #1 SMP Wed Aug 17 20:22:22 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
always

Steps to Reproduce:
1. Download a boot.iso of rhel5.7.
2. Click on the local connection.
3. Click NEW button at the top of Virtual Machine Manager dialog.
4. Fill out virtual machine name and Select "Local install media (ISO image or CDROM)",and Click "Forward" button.
5. Select "Use ISO image",browse your local directory and select boot.iso file, then select os type on OS Type drop-down list, select os version on OS version drop-down list.
6. Click "Forward" button.
7. Select Memory and CPUs, and click Forward. (such as 512M and 2 cpus)
8. Check "Enable storage for this virtual machine",Select the size for "create a disk image on the comupter's hard drive,check "Allocate entire disk now".
9. Click "Forward" button.
10. Open "Advanced options",check "Set a fixed mac address",select the correct architecture according to the http url. untick "Customize configuration before install".
11. Follow the info to install system.
12. After installation, the guest need to reboot.
13. After reboot, check the Boot options.
  
Actual results:
CDROM Boot options was enabled and the installation screen displayed again.Customer can not login the guest OS by default.

Expected results:
CDROM should not be enabled just like installing VM from CDROM or HTTP.

Workaround:
Downgrade the CDROM Boot device order or disabled CDROM Boot after installation.

Additional info:

Comment 2 RHEL Product and Program Management 2011-10-07 16:11:35 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 3 Cole Robinson 2011-10-13 19:39:03 UTC
I can't reproduce this. I followed your steps, when guest install completed, I cliked anaconda's (the RHEL5 installer) reboot button. guest shutdown, rebooted, and correctly booted into the operating system.

Can you regularly reproduce this issue? If so, please provide the output of virt-manager --debug when following your above steps.

Since I can't reproduce, deferring to 6.2 for now.

Comment 4 Daisy Wu 2011-10-17 02:24:51 UTC
The libvirt-0.9.4-9.el6 was deleted on the brewweb server, then I can not reproduce this issue on below environment, so closed current release.

virt-manager-0.9.0-7.el6
kernel-2.6.32-206.el6.x86_64
libvirt-0.9.4-17.el6
python-virtinst-0.600.0-3.el6
qemu-kvm-0.12.1.2-2.195.el6.x86_64


Note You need to log in before you can comment on or make changes to this bug.