Bug 739007 - Window title is missing the name of the guest
Summary: Window title is missing the name of the guest
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Daniel Berrangé
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-16 10:16 UTC by Daniel Berrangé
Modified: 2011-12-06 15:07 UTC (History)
4 users (show)

Fixed In Version: virt-viewer-0.4.1-5.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 15:07:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1614 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2011-12-06 00:51:05 UTC

Description Daniel Berrangé 2011-09-16 10:16:47 UTC
Description of problem:
The window title for virt-viewer instances does not contain the name of the guest being displayed, nor does it contain the display number (for multi-head) guests.

Version-Release number of selected component (if applicable):
0.4.1-4.el6

How reproducible:
Always

Steps to Reproduce:
1. virt-viewer rhel6guest
2.
3.
  
Actual results:
Window title is  'Virt Viewer'

Expected results:
Window title is 'rhel6guest (1) - Virt Viewer'

Additional info:
If the guest has multiple displays it should be showing

Window title is 'rhel6guest (1) - Virt Viewer'
Window title is 'rhel6guest (2) - Virt Viewer'
Window title is 'rhel6guest (3) - Virt Viewer'
etc for each window.

Comment 1 Daniel Berrangé 2011-09-16 10:17:38 UTC
Fix available upstream with:

commit 46cf6410c11dc8369dcf74283656f4bb0e14be8a
Author: Daniel P. Berrange <berrange@redhat.com>
Date:   Fri Sep 16 10:57:53 2011 +0100

    Fix setting of window title with domain name

Comment 4 zhe peng 2011-09-20 06:51:13 UTC
can reproduce with :
virt-viewer-0.4.1-4.el6

verify with:
virt-viewer-0.4.1-5.el6

step:
1: prepare a windows guest with multiple graphics cards(this test guest have
three qxl graphics cards).
#virsh dumpxml winxp
.....
 <graphics type='spice' port='5901' tlsPort='-1' autoport='yes'
listen='0.0.0.0'>
      <listen type='address' address='0.0.0.0'/>
    </graphics>
.....
 <video>
      <model type='qxl' vram='65536' heads='1'/>
      <alias name='video0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02'
function='0x0'/>
    </video>
    <video>
      <model type='qxl' vram='65536' heads='1'/>
      <alias name='video1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06'
function='0x0'/>
    </video>
    <video>
      <model type='qxl' vram='65536' heads='1'/>
      <alias name='video2'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x08'
function='0x0'/>
    </video>
.....

2:start the guest,popup three windows,
the window's title is:
 winxp(1) - Virt Viewer
 winxp(2) - Virt Viewer
 winxp(3) - Virt Viewer

3:test guest vnc with one graphic cards
#virsh dumpxml win2008
 <graphics type='vnc' port='5900' autoport='yes' listen='0.0.0.0'>
      <listen type='address' address='0.0.0.0'/>
    </graphics>
    <video>
      <model type='cirrus' vram='9216' heads='1'/>
      <alias name='video0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
#virt-viewer win2008
the window's title is:
 win2008(1) - Virt Viewer


verification passed.

Comment 5 errata-xmlrpc 2011-12-06 15:07:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1614.html


Note You need to log in before you can comment on or make changes to this bug.