Bug 73907 - Does not work when installed with an umask of 077 and messes filesystem
Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED DUPLICATE of bug 152536
Product: Red Hat Linux
Classification: Retired
Component: perl-Compress-Zlib (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-13 09:46 EDT by Enrico Scholz
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 07:18:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-09-13 09:46:06 EDT
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
them.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/auto/Compress/Zlib /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/auto/Compress/Zlib/Zlib.bs
| file /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/auto/Compress/Zlib is not owned by any package
| perl-Compress-Zlib-1.16-8


Version-Release number of selected component (if applicable):

perl-Compress-Zlib-1.16-8


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that perl-Compress-Zlib is uninstalled completely
   (rm -rf /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/auto/Compress/Zlib)
3. rpm -U perl-Compress-Zlib-1.16-8.*
4. ls -l /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/auto/Compress/Zlib
5. start perl script using this module
6. rpm -e perl-Compress-Zlib-1.16-8

Actual Results:

| drwx------    2 root     root         4096 Sep 13 13:57 /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/auto/Compress/Zlib

at 4; script can not find package at 5 and
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/auto/Compress/Zlib
still exists after 6.
Comment 1 Joe Orton 2005-03-31 07:18:40 EST

*** This bug has been marked as a duplicate of 152536 ***

Note You need to log in before you can comment on or make changes to this bug.