Bug 73908 - Does not work when installed with an umask of 077 and messes filesystem
Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Crypt-SSLeay (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-13 09:46 EDT by Enrico Scholz
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-24 16:29:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Suggested fix + other improvements (3.25 KB, patch)
2005-09-24 03:51 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Enrico Scholz 2002-09-13 09:46:16 EDT
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
them.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/Crypt/SSLeay /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/Crypt/SSLeay/CTX.pm
| file /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/Crypt/SSLeay is not owned by any package
| perl-Crypt-SSLeay-0.45-2


Version-Release number of selected component (if applicable):

perl-Crypt-SSLeay-0.45-2


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that perl-Crypt-SSLeay is uninstalled completely
   (rm -rf /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/Crypt/SSLeay)
3. rpm -U perl-Crypt-SSLeay-0.45-2.*
4. ls -l /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/Crypt/SSLeay
5. start perl script using this module
6. rpm -e perl-Crypt-SSLeay-0.45-2

Actual Results:

| drwx------    2 root     root         4096 Sep 13 15:11 /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/Crypt/SSLeay

at 4; script can not find package at 5 and
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/Crypt/SSLeay
still exists after 6.
Comment 1 Warren Togami 2005-09-11 07:35:31 EDT
This package has not been cleaned up since then, so likely still needs fixing.
Comment 2 Ville Skyttä 2005-09-24 03:51:33 EDT
Created attachment 119219 [details]
Suggested fix + other improvements
Comment 3 Warren Togami 2005-09-24 16:29:27 EDT
thanks built

Note You need to log in before you can comment on or make changes to this bug.