Bug 739130 - x86_64 gnome-shell accepts i686 caribou as its dependency
x86_64 gnome-shell accepts i686 caribou as its dependency
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
: 753649 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-16 11:26 EDT by Joonas Sarajärvi
Modified: 2011-11-20 16:38 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-16 12:36:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joonas Sarajärvi 2011-09-16 11:26:08 EDT
Description of problem:
Fedora 16 x86_64 has both x86_64 and i686 versions of caribou. gnome-shell package on x86_64 seems to accept a i686 version of caribou to fill the dependency, but it will not work with that arch's version.

Version-Release number of selected component (if applicable):
gnome-shell-3.1.91-2.fc16.x86_64
Comment 1 Kalev Lember 2011-09-16 12:36:28 EDT
Thanks for the report, Joonas!

Fixed in gnome-shell-3.1.91.1-2 in git; not doing a build for F16 just for this change, but it will be in the next build.

http://pkgs.fedoraproject.org/gitweb/?p=gnome-shell.git;a=commitdiff;h=2706e12829ecc45f117c92c4ce8c12217dcbce9f
Comment 2 Dave Ludlow 2011-11-20 16:28:40 EST
*** Bug 753649 has been marked as a duplicate of this bug. ***
Comment 3 Dave Ludlow 2011-11-20 16:38:50 EST
This requirement isn't being enforced on upgrade from F15; caribou.noarch is being replaced by caribou.i686.  See Bug 753649.

Note You need to log in before you can comment on or make changes to this bug.