Bug 739188 - FTBFS: gettext 0.18.1.1 on kernel >= 2.6.39
FTBFS: gettext 0.18.1.1 on kernel >= 2.6.39
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gettext (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-16 14:00 EDT by DJ Delorie
Modified: 2011-10-12 20:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: gettext-0.18.1.1-8.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-09 15:49:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to check for EINVAL also (1.27 KB, application/octet-stream)
2011-09-16 14:00 EDT, DJ Delorie
no flags Details

  None (edit)
Description DJ Delorie 2011-09-16 14:00:58 EDT
Created attachment 523596 [details]
patch to check for EINVAL also

gettext 0.18.1.1 will FTBFS on any builder with kernel >= 2.6.39 due to:

http://lists.gnu.org/archive/html/bug-gnulib/2011-03/msg00308.html

The symptom is failures in its testsuite for readlink and areadlink.
Comment 1 Jens Petersen 2011-09-28 04:57:21 EDT
Thank you for the report.

Should be fixed in gettext-0.18.1.1-8.fc17.

I can backport to F16 and F15, if necessary.
Comment 2 DJ Delorie 2011-09-28 12:32:27 EDT
Thanks!

Yes please, we need official SRPMs for our F15 ARMv7hl bootstrap.
Comment 3 Fedora Update System 2011-09-29 07:13:54 EDT
gettext-0.18.1.1-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gettext-0.18.1.1-8.fc15
Comment 4 Fedora Update System 2011-09-29 07:14:04 EDT
gettext-0.18.1.1-8.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gettext-0.18.1.1-8.fc16
Comment 5 Fedora Update System 2011-09-29 13:12:41 EDT
Package gettext-0.18.1.1-8.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gettext-0.18.1.1-8.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gettext-0.18.1.1-8.fc16
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2011-10-09 15:49:28 EDT
gettext-0.18.1.1-8.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2011-10-12 20:48:26 EDT
gettext-0.18.1.1-8.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.