Bug 739189 - FTBFS: m4 1.4.16 on kernel >= 2.6.39
FTBFS: m4 1.4.16 on kernel >= 2.6.39
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: m4 (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-16 14:03 EDT by DJ Delorie
Modified: 2011-10-18 18:12 EDT (History)
1 user (show)

See Also:
Fixed In Version: m4-1.4.16-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-18 18:12:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to check for EINVAL also (343 bytes, application/octet-stream)
2011-09-16 14:03 EDT, DJ Delorie
no flags Details

  None (edit)
Description DJ Delorie 2011-09-16 14:03:39 EDT
Created attachment 523597 [details]
patch to check for EINVAL also

m4 1.4.16 will FTBFS on any builder with kernel >= 2.6.39 due to:

http://lists.gnu.org/archive/html/bug-gnulib/2011-03/msg00308.html

The symptom is a failure in its testsuite for readlink.
Comment 1 Fedora Update System 2011-09-20 07:10:16 EDT
m4-1.4.16-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/m4-1.4.16-2.fc16
Comment 2 Fedora Update System 2011-09-20 07:32:25 EDT
m4-1.4.16-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/m4-1.4.16-2.fc15
Comment 3 Fedora Update System 2011-09-20 20:00:24 EDT
Package m4-1.4.16-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing m4-1.4.16-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/m4-1.4.16-2.fc15
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2011-10-10 23:17:30 EDT
m4-1.4.16-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2011-10-18 18:12:51 EDT
m4-1.4.16-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.