Bug 739197 - iscsi initiator name is hardcoded, should be randomly generated during installation
Summary: iscsi initiator name is hardcoded, should be randomly generated during insta...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Mike Burns
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-16 18:26 UTC by Andrew Cathrow
Modified: 2014-09-07 22:54 UTC (History)
11 users (show)

Fixed In Version: ovirt-node-2.0.2-0.7.gitb88a4ee.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 19:27:59 UTC


Attachments (Terms of Use)
Patch (1.59 KB, patch)
2011-09-16 23:04 UTC, Mike Burns
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1783 normal SHIPPED_LIVE rhev-hypervisor6 bug fix and enhancement update 2011-12-06 15:10:54 UTC

Description Andrew Cathrow 2011-09-16 18:26:00 UTC
iscsi intiator name is hardcoded to iqn.1994-05.com.redhat:7a28edbfc51d
Initiator should be unique and regenerated as part of installation.

Regression from RHEL 5 
https://bugzilla.redhat.com/show_bug.cgi?id=513456

Comment 1 Mike Burns 2011-09-16 18:46:38 UTC
This needs a 2 part fix:

for autoinstall, we will run ovirt-config-iscsi which we weren't previously.  This sets and persists with the value of iscsi-name command line variable or a random initiator name if one is not provided.

For TUI, we will do a similar process.

Comment 2 Mike Burns 2011-09-16 23:04:16 UTC
Created attachment 523664 [details]
Patch

Comment 5 Ying Cui 2011-10-11 08:20:47 UTC
Verified this bug with rhevh 6.2-20111006 build.

for auto install, user can specify iscsi_name parameter successful.
for TUI install, the intiator name is generated randomly successful.

Comment 6 errata-xmlrpc 2011-12-06 19:27:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html


Note You need to log in before you can comment on or make changes to this bug.