Bug 739242 - xorg-x11-proto-devel SRPM rebuild fails with xmlto installed
Summary: xorg-x11-proto-devel SRPM rebuild fails with xmlto installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-proto-devel
Version: 6.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: 6.2
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-16 22:27 UTC by Mark Gordon
Modified: 2013-07-28 23:41 UTC (History)
3 users (show)

Fixed In Version: xorg-x11-proto-devel-7.6-13.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 15:06:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1613 normal SHIPPED_LIVE X.Org support packages bug fix and enhancement update 2011-12-06 00:51:05 UTC

Description Mark Gordon 2011-09-16 22:27:42 UTC
Description of problem:
If xmlto is installed, the configure script for recordproto builds a bunch of docs which are neither deleted nor packaged, causing TPS failures (SRPM rebuild).

Version-Release number of selected component (if applicable):
xorg-x11-proto-devel-7.6-12.el6

How reproducible:
100%

Steps to Reproduce:
1. Install xmlto (optionall xmlto-tex as well)
2. rpmbuild -ba xorg-x11-proto-defel.spec
  
Actual results:
4266:error: Installed (but unpackaged) file(s) found: 
4267- /usr/share/doc/recordproto/record.pdf 
4268- /usr/share/doc/recordproto/record.ps 
4269- /usr/share/doc/scrnsaverproto/saver.pdf 
4270- /usr/share/doc/scrnsaverproto/saver.ps 
4271- /usr/share/doc/xcmiscproto/xc-misc.pdf
(this seems to be the result of other xmlto-foo being installed as well, but xmlto alone is enough to make it fail)

Expected results:
Successful build

Additional info:
If I edit the spec file to pass --without-xmlto to %configure, it skips building the docs, and the rebuild works reliably.  Alternatively, if I uninstall xmlto, rebuild works.

Comment 4 Adam Jackson 2011-09-21 17:20:50 UTC
3654913 build (RHEL-6-candidate, /cvs/dist:rpms/xorg-x11-proto-devel/RHEL-6:xorg-x11-proto-devel-7_6-13_el6) completed successfully

MODIFIED

Comment 7 errata-xmlrpc 2011-12-06 15:06:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1613.html


Note You need to log in before you can comment on or make changes to this bug.