Bug 73925 - Does not work when installed with an umask of 077 and messes filesystem
Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: perl-TimeDate (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-13 09:54 EDT by Enrico Scholz
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-11 07:21:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-09-13 09:54:04 EDT
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
them.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/lib/perl5/vendor_perl/5.8.0/Date/Language /usr/lib/perl5/vendor_perl/5.8.0/Date/Language/Austrian.pm
| file /usr/lib/perl5/vendor_perl/5.8.0/Date/Language is not owned by any package
| perl-TimeDate-1.1301-2


Version-Release number of selected component (if applicable):

perl-TimeDate-1.1301-2


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that perl-TimeDate is uninstalled completely
   (rm -rf /usr/lib/perl5/vendor_perl/5.8.0/Date/Language)
3. rpm -U perl-TimeDate-1.1301-2.*
4. ls -l /usr/lib/perl5/vendor_perl/5.8.0/Date/Language
5. start perl script using this module
6. rpm -e perl-TimeDate-1.1301-2

Actual Results:

| drwx------    2 root     root         4096 Sep 13 15:41 /usr/lib/perl5/vendor_perl/5.8.0/Date/Language

at 4; script can not find package at 5 and
/usr/lib/perl5/vendor_perl/5.8.0/Date/Language
still exists after 6.


Additional Information:

When adding

| for i in installarchlib vendorlib; do
| 	eval $(perl "-V:$i")
| 	dir=$(eval echo \$$i)
|
|       echo "%exclude %dir ${dir}"
| 	find "${RPM_BUILD_ROOT}${dir}" -type d -mindepth 1 ! -empty -print |	\
| 		sed "s@^$RPM_BUILD_ROOT@%dir @g"
| done | sort -u >> %{modname}-%{version}-filelist

to the file-finding section in the spec-file, this class of bugs can
be fixed for all perl-XXX packages.
Comment 1 Warren Togami 2005-09-11 07:21:06 EDT
Spec has since been rewritten so assuming fixed.  If this is not fixed in
rawhide then please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.