Bug 739325 - Can't print a specific gif file from Firefox/Gimp/Okular
Summary: Can't print a specific gif file from Firefox/Gimp/Okular
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL: http://www.osh.com/eng/coupons/110917...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-17 17:48 UTC by Konstantin Svist
Modified: 2013-02-13 23:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-13 23:47:14 UTC


Attachments (Terms of Use)
printing problem debug log (178.84 KB, text/plain)
2011-09-19 16:27 UTC, Konstantin Svist
no flags Details
This image fails to print (83.43 KB, image/gif)
2011-09-20 17:48 UTC, Konstantin Svist
no flags Details
output of pdftops (238.16 KB, text/plain)
2011-12-19 16:50 UTC, Tim Waugh
no flags Details
Brother-MFC-8840D.ppd (18.41 KB, application/vnd.cups-ppd)
2011-12-20 18:20 UTC, Konstantin Svist
no flags Details


Links
System ID Priority Status Summary Last Updated
CUPS Bugs and Features 3950 None None None Never

Description Konstantin Svist 2011-09-17 17:48:16 UTC
Description of problem:
When trying to print the page above to networked Apple 12/640ps, the job gets submitted okay and disappears from the computer, but the printer doesn't react except for blinking a light.
This is not the case with other webpages or applications (they print okay). Printing this page to file (.ps), to Cups-PDF, and print preview all work, too.


Version-Release number of selected component (if applicable):

1st machine i686, upgraded F14 -> F15:
2.6.40.4-5.fc15.i686
cups.i686  1:1.4.8-2.fc15
firefox.i686  6.0.2-1.fc15
--- BROKEN

2nd machine x64, upgraded F14 -> F15:
2.6.40.3-0.fc15.x86_64
cups.x86_64  1:1.4.8-2.fc15
firefox.x86_64  6.0-1.fc15
--- BROKEN

3rd machine x64, F14:
2.6.35.13-92.fc14.x86_64
cups.x86_64  1:1.4.6-1.fc14
firefox4.x86_64  4.0.1-2.fc14
--- WORKING (takes a long time to process, but prints)

How reproducible:
every time

Comment 1 Jiri Popelka 2011-09-19 10:07:11 UTC
Printing that page from Firefox works here on fully updated F15.

Can you attach an output from printing troubleshooter ?
https://fedoraproject.org/wiki/Printing/Debugging#Printing_troubleshooter
When it asks you to print test page, print the above mentioned page from Firefox instead. Thanks

Comment 2 Konstantin Svist 2011-09-19 16:27:08 UTC
Created attachment 523866 [details]
printing problem debug log

Comment 3 Konstantin Svist 2011-09-19 22:03:49 UTC
Are you sure you have the same printer? I just tried printing to a different printer from the affected machine, and it goes through without a problem.
Problem seems to be very specific

Comment 4 Konstantin Svist 2011-09-19 22:08:22 UTC
Correction: 2nd printer (Brother MFC-8840D) does NOT print correctly, either

Comment 5 Tim Waugh 2011-09-20 11:05:44 UTC
More information is needed:

1. Please compare RPM versions of 'foomatic-db' between the working and non-working systems.  What versions are you using on each?

2. "Printing this page to file (.ps), to Cups-PDF, and print preview all work, too."
Do you mean that you can successfully print by printing to file, and then printing that file to the printer? Or just that the printing-to-file step works, and displays fine on-screen?

Comment 6 Konstantin Svist 2011-09-20 17:47:57 UTC
BROKEN
foomatic.i686  4.0.7-3.fc15
foomatic-db.noarch  4.0-28.20110221.fc15

WORKING
foomatic.x86_64  4.0.5-1.fc14
foomatic-db.noarch  4.0-23.20101123.fc14

PostScript file is created (viewing it works), and printing it from Okular works too.

Comment 7 Konstantin Svist 2011-09-20 17:48:50 UTC
Created attachment 524076 [details]
This image fails to print

I've extracted the gif from the webpage - apparently that's the part that won't print. So far, it failed to print from Firefox, Gimp, and Okular after being saved to local HDD.

Attaching the gif to the bug in case webpage disappears.

Comment 8 Jiri Popelka 2011-09-21 08:12:00 UTC
I'm still unable to reproduce it.
I tried to print the image from Gimp and Okular.
Having also foomatic-4.0.7-3.fc15 and using LPD backend.

Can you update foomatic package on F14 machine to latest version (foomatic-4.0.7-2.fc14 should be in stable repo) and try it again ?

Comment 9 Konstantin Svist 2011-09-21 18:19:19 UTC
Updated foomatic on F14 - printing from Firefox still works.

More details:
F14:
Firefox  4.0.1  PASS
Okular  0.12.2  FAIL
Gimp    2.6.11  PASS


F15:
Firefox  6.0.2  FAIL
Okular  0.12.5  FAIL
Gimp     2.7.3  FAIL

Comment 10 Konstantin Svist 2011-09-29 06:05:21 UTC
Since original report I've hit the bug 4 times on random prints, this is becoming a really big deal.
Someone please help!

Comment 11 Konstantin Svist 2011-12-15 22:22:42 UTC
upgraded to Fedora 16 -- it still doesn't print

Tested on brother mfc-8840D
Printer prints following on the page:
ERROR NAME;
  configurationerror
COMMAND;
  setpagedevice
OPERAND STACK;
  --dicttype--

Comment 12 Tim Waugh 2011-12-19 16:48:41 UTC
There are two trays installed in this printer, not one?

Comment 13 Tim Waugh 2011-12-19 16:50:38 UTC
Created attachment 548640 [details]
output of pdftops

Can you confirm that printing this file fails in the same way?  You need to print it as a raw job, i.e. like this:

lp -oraw -dApple-12-640ps pdftops.ps

Comment 14 Konstantin Svist 2011-12-19 22:38:22 UTC
(In reply to comment #12)

Correct, 2 trays. But I'm only using the main feed.


(In reply to comment #13)

I no longer have the Apple 12/640ps, but the command sent to Brother MFC-8840D resulted in the same error as in comment #11

Comment 15 Tim Waugh 2011-12-20 10:40:38 UTC
Oh -- could you please attach the PPD you're using for that printer?  Thanks.

Comment 16 Konstantin Svist 2011-12-20 18:20:24 UTC
Created attachment 548912 [details]
Brother-MFC-8840D.ppd

here you go

Comment 17 Jochen Wiedmann 2012-01-25 21:37:53 UTC
Confirming the same poblem with Fedora 16 and a Brother MFC7820N.

Comment 18 Jochen Wiedmann 2012-01-25 21:41:48 UTC
Additional info: I am observing this bug typically with PDF files when printing from the Adobe Reader plugin for Firefox. As a workaround, I save the PDF file and print it with evince. So far, this worked for me.
(Sorry, I have one tray only.)

Comment 19 Konstantin Svist 2012-07-16 16:57:00 UTC
This bug is so annoying! And even more annoying that nobody wants to get it fixed :(

Comment 20 Tim Waugh 2012-07-17 14:16:09 UTC
It's just down to a lack of time to look into it. :-(  At the moment there are higher priority issues.

Comment 21 Konstantin Svist 2012-12-06 23:17:30 UTC
Still no time?
Because I still can't print!

Comment 22 Jiri Popelka 2012-12-07 10:04:16 UTC
FYI: there are more Brother-MFC bugs, like:
bug #668059: MFC-8840D
bug #795824: MFC-7820N
bug #855009: MFC-9840CDW

Comment 23 Fedora End Of Life 2013-01-16 20:22:46 UTC
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 24 Fedora End Of Life 2013-02-13 23:47:18 UTC
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.