Bug 739335 - python-repoze-who-friendlyform 1.0.8-2.el6 causes luci-0.23.0-17.el6.x86_64 to fail to start
Summary: python-repoze-who-friendlyform 1.0.8-2.el6 causes luci-0.23.0-17.el6.x86_64 t...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-repoze-who-friendlyform
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-17 20:12 UTC by Thomas Cameron
Modified: 2014-02-19 15:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-19 15:35:52 UTC


Attachments (Terms of Use)
abrt report (1.07 MB, application/x-gzip)
2011-09-17 20:12 UTC, Thomas Cameron
no flags Details

Description Thomas Cameron 2011-09-17 20:12:01 UTC
Created attachment 523725 [details]
abrt report

Description of problem:
I ran yum update today on my rhel6 x86_64 box. Luci no longer starts. An abrt report is created.

Version-Release number of selected component (if applicable):
python-repoze-who-friendlyform 1.0.8-2.el6 vs. luci-0.23.0-17.el6.x86_64

How reproducible:
yum update 
service luci restart

Steps to Reproduce:
1.
2.
3.
  
Actual results:
service luci start indicates the service has started, but it does not

Expected results:
service starts

Additional info:

Comment 2 RHEL Product and Program Management 2011-09-17 20:27:59 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Dave Malcolm 2011-09-19 16:45:33 UTC
AFAIK, the only N-V-R of that package that Red Hat has shipped was:
  python-repoze-who-friendlyform-1.0-0.3.b3.el6

It looks like that version of friendlyform is in EPEL 6:
  http://koji.fedoraproject.org/koji/buildinfo?buildID=258047

but appears to be the only version that's been built into EPEL6:
  http://koji.fedoraproject.org/koji/packageinfo?packageID=8496


Looking in backtrace in that ABRT tarball I see the error is:
  pkg_resources.py:550:resolve:VersionConflict: (WebOb 0.9.6.1 (/usr/lib/python2.6/site-packages), Requirement.parse('WebOb>=0.9.7'))


Looking in the 1.0.8 tarball, within:
  repoze.who-friendlyform-1.0.8/setup.py
I see:
  install_requires=['repoze.who >= 1.0', 'zope.interface', 'WebOb>=0.9.7'],

whereas in the 1.0b3 tarball, within:
  repoze.who-friendlyform-1.0b3/setup.py
I merely see:
  install_requires=['repoze.who >= 1.0', 'zope.interface'],


That new requirement on "WebOb" isn't reflected in the metadata of that EPEL6 rpm, and currently, within RHEL6, we're shipping python-webob-0.9.6.1, which wouldn't satisfy that version.

CCing Toshio re the EPEL6 package.

Comment 4 Thomas Cameron 2011-09-19 18:53:22 UTC
I am sorry I didn't realize this was an EPEL package! Do I need to close this and open a different BZ?

Comment 5 Bohuslav "Slavek" Kabrda 2014-02-14 12:58:30 UTC
Reassigning to EPEL package as per comment 3. I thought that EPEL shouldn't ship a package if RHEL has it. Is that not true?

Comment 6 Tom "spot" Callaway 2014-02-14 15:33:34 UTC
Wow, three year old bug. :) Yes, EPEL should not ship a package if RHEL has it. I'll figure out how to get this blocked in epel 6.

Comment 7 Tom "spot" Callaway 2014-02-19 15:35:52 UTC
Retired in pkgdb and git, ticket filed to block in EPEL. Won't help those people who already have the package installed, but new users shouldn't hit this issue.


Note You need to log in before you can comment on or make changes to this bug.