Bug 739344 - regression from 5.6 'cp -b' issue from upstream
Summary: regression from 5.6 'cp -b' issue from upstream
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: coreutils
Version: 5.7
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ondrej Vasik
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-17 21:47 UTC by Tru Huynh
Modified: 2013-11-26 12:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-26 12:23:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
CentOS 5119 None None None Never

Description Tru Huynh 2011-09-17 21:47:12 UTC
Description of problem:
cp: Dosn't make a backup if the last component of the source name is "."

Version-Release number of selected component (if applicable):
coreutils-5.97-34.el5

How reproducible:
always

Steps to Reproduce:
1. mkdir x y
2. cd y
3. cp -ab ../x/. .
  
Actual results:
cp: cannot backup `./.': Device or resource busy

Expected results:
no errors

Additional info:
http://www.mail-archive.com/bug-coreutils@gnu.org/msg07615.html

Comment 1 Tru Huynh 2011-09-17 21:48:00 UTC
copied verbatim from CentOS entry

Comment 2 RHEL Product and Program Management 2011-09-23 00:09:46 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 3 RHEL Product and Program Management 2012-06-12 01:02:19 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 4 RHEL Product and Program Management 2013-05-01 06:42:32 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 7 Ondrej Vasik 2013-11-26 12:23:28 UTC
This Bugzilla has been reviewed by Red Hat and is not planned on being
addressed in Red Hat Enterprise Linux 5, and therefore will be closed.
If this bug is critical to production systems, please contact your Red
Hat support representative and provide sufficient business
justification.
Issue is already fixed in RHEL-6/7.


Note You need to log in before you can comment on or make changes to this bug.