Bug 73938 - Does not work when installed with an umask of 077 and messes filesystem
Summary: Does not work when installed with an umask of 077 and messes filesystem
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: aspell   
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL: http://www.tu-chemnitz.de/~ensc/dirch...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-13 15:11 UTC by Enrico Scholz
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-19 20:57:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2002-09-13 15:11:27 UTC
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /usr/lib/aspell /usr/lib/aspell/american-med-only
| file /usr/lib/aspell is not owned by any package
| aspell-0.33.7.1-16


Version-Release number of selected component (if applicable):

aspell-0.33.7.1-16


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that aspell is uninstalled completely
   (rm -rf /usr/lib/aspell)
3. rpm -U aspell-0.33.7.1-16.i386.rpm
4. ls -l /usr/lib/aspell
5. use the programs/scripts/libraries of the package as non-root user
6. rpm -e aspell-0.33.7.1-16

Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 16:57 /usr/lib/aspell
* files can not be found/read at 5 and
* /usr/lib/aspell still exists after 6.

Comment 1 Eido Inoue 2003-02-19 20:57:49 UTC
aspell will be revamped in the next release


Note You need to log in before you can comment on or make changes to this bug.