Bug 739412 - apm_32.c kernel BUG
Summary: apm_32.c kernel BUG
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-18 20:54 UTC by Mr-4
Modified: 2012-01-15 15:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-15 14:50:28 UTC


Attachments (Terms of Use)

Description Mr-4 2011-09-18 20:54:52 UTC
Description of problem:
During startup (Thinkpad 600E, PII processor) I get the following kernel oops:

Sep 18 01:16:12 test1 kernel: [    1.541331] ------------[ cut here ]------------
Sep 18 01:16:12 test1 kernel: [    1.541393] WARNING: at arch/x86/kernel/apm_32.c:908 apm_cpu_idle+0x3f/0x23c()
Sep 18 01:16:12 test1 kernel: [    1.541414] Hardware name:        
Sep 18 01:16:12 test1 kernel: [    1.541428] deprecated apm_cpu_idle will be deleted in 2012
Sep 18 01:16:12 test1 kernel: [    1.541444] Modules linked in:
Sep 18 01:16:12 test1 kernel: [    1.541472] Pid: 0, comm: swapper Not tainted 2.6.40.4-5.fc13.i686 #1
Sep 18 01:16:12 test1 kernel: [    1.541491] Call Trace:
Sep 18 01:16:12 test1 kernel: [    1.541562]  [<c0428cf1>] warn_slowpath_common+0x7c/0x91
Sep 18 01:16:12 test1 kernel: [    1.541592]  [<c04157aa>] ? apm_cpu_idle+0x3f/0x23c
Sep 18 01:16:12 test1 kernel: [    1.541620]  [<c04157aa>] ? apm_cpu_idle+0x3f/0x23c
Sep 18 01:16:12 test1 kernel: [    1.541652]  [<c0428d91>] warn_slowpath_fmt+0x33/0x35
Sep 18 01:16:12 test1 kernel: [    1.541680]  [<c04157aa>] apm_cpu_idle+0x3f/0x23c
Sep 18 01:16:12 test1 kernel: [    1.541712]  [<c0401d17>] cpu_idle+0x72/0x8f
Sep 18 01:16:12 test1 kernel: [    1.541774]  [<c0777b07>] rest_init+0x57/0x59
Sep 18 01:16:12 test1 kernel: [    1.541808]  [<c09197e1>] start_kernel+0x31b/0x321
Sep 18 01:16:12 test1 kernel: [    1.541834]  [<c09192fe>] ? kernel_init+0x118/0x118
Sep 18 01:16:12 test1 kernel: [    1.541864]  [<c09190b2>] i386_start_kernel+0xb2/0xba
Sep 18 01:16:12 test1 kernel: [    1.541911] ---[ end trace a22d306b065d4a66 ]---


Version-Release number of selected component (if applicable):
the latest kernel compiled from source as distributed by Fedora. I can provide the actual .config file, if needed. 

Please note that apm is used instead of ACPI due to errata on that particular thinkpad model number and cpu!

How reproducible:
always

Steps to Reproduce:
1. compile and install the kernel, activating apm instead of acpi, lapic is also off due to errata on this particular thinkpad model and cpu.
2. On boot, the above should appear
3.
  
Actual results:
As shown above

Expected results:
No errors

Additional info:
During compilation I get the following message:

warning: (ACPI_PROCESSOR) selects CPU_FREQ_TABLE which has unmet direct dependencies (CPU_FREQ)

I do not know how relevant this is though. It is also worth noting that it is the first time I am getting this message. When compiling the previous kernel revision (.40.2-3 I think) I did not have that issue. 

Finally, to reiterate once again - I cannot use ACPI on that machine due to errata on that specific model Thinkpad (600E with PII Deschute) - only apm is usable, unfortunately, lapic is also disabled for the same purpose!

Comment 1 Chuck Ebbert 2011-09-20 11:06:30 UTC
That's just a warning that the APM support will be removed next year.

Comment 2 Mr-4 2012-01-15 04:58:21 UTC
I would like to re-open this as the issue is getting much worse - I am now getting a constant message that APM is going to be discontinued in 2012 (!) and that repeats non-stop to the point where my machine becomes unusable.

Looking at the code for 2.6.41.4-1 (apm_32.c) the warning message has been changed from warn once to printk, which causes all this.

The reason I *have* to use apm instead of acpi is this:

Jan 15 04:07:18 test1 kernel: [    0.000000] ACPI: Vendor "IBM   " System "TP600E  " Revision 0x105 has a known ACPI BIOS problem.
Jan 15 04:07:18 test1 kernel: [    0.000000] ACPI: Reason: Incorrect _ADR. This is a non-recoverable error
Jan 15 04:07:18 test1 kernel: [    0.000000] ACPI: Disabling ACPI support

In other words, this is a known ERRATA on IBM Thinkpad 600E machines preventing ACPI from being used (if you know how to activate/use ACPI and completely ditch APM I am certainly open to suggestions!).

At present, the only way to use the above kernel on my machine is comment out the above message and recompile the kernel.

Comment 3 Josh Boyer 2012-01-15 14:50:28 UTC
(In reply to comment #2)
> I would like to re-open this as the issue is getting much worse - I am now
> getting a constant message that APM is going to be discontinued in 2012 (!) and
> that repeats non-stop to the point where my machine becomes unusable.
> 
> Looking at the code for 2.6.41.4-1 (apm_32.c) the warning message has been
> changed from warn once to printk, which causes all this.

That was fixed in 2.6.41.5 or newer.  Please update.

> The reason I *have* to use apm instead of acpi is this:
> 
> Jan 15 04:07:18 test1 kernel: [    0.000000] ACPI: Vendor "IBM   " System
> "TP600E  " Revision 0x105 has a known ACPI BIOS problem.
> Jan 15 04:07:18 test1 kernel: [    0.000000] ACPI: Reason: Incorrect _ADR. This
> is a non-recoverable error
> Jan 15 04:07:18 test1 kernel: [    0.000000] ACPI: Disabling ACPI support
> 
> In other words, this is a known ERRATA on IBM Thinkpad 600E machines preventing
> ACPI from being used (if you know how to activate/use ACPI and completely ditch
> APM I am certainly open to suggestions!).

I have no idea to be honest.  Have you checked to see if there is a BIOS update for your machine that fixes the ACPI issue?

Comment 4 Mr-4 2012-01-15 15:47:18 UTC
According to my update repository, I have the latest version of the kernel - 2.6.41.4-1 (2.6.41.9-1 is still in "testing"). Am I missing something?

As for my BIOS, I tried to do that last year and could not find a solution, but will check again in case something has come up. Thanks!

Comment 5 Josh Boyer 2012-01-15 15:52:21 UTC
(In reply to comment #4)
> According to my update repository, I have the latest version of the kernel -
> 2.6.41.4-1 (2.6.41.9-1 is still in "testing"). Am I missing something?

No, you are right.  I think 2.6.41.9 will be pushed to the update repository later today.


Note You need to log in before you can comment on or make changes to this bug.