Bug 73943 - gnome-vfs should own /etc/vfs
gnome-vfs should own /etc/vfs
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-vfs (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
http://www.tu-chemnitz.de/~ensc/dirch...
: EasyFix, Triaged
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-09-13 11:23 EDT by Enrico Scholz
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-25 10:04:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-09-13 11:23:10 EDT
Description of Problem:

Because this package contains unowned directories, they will be created
with the current umask. When having restrictive administrator settings
(umask 077) ordinary user will not have access to them and can not use
the package.

Another problem occurs when removing packages. Then orphaned directories
are remaining.

| $ rpm -qf /etc/vfs /etc/vfs/modules/default-modules.conf
| file /etc/vfs is not owned by any package
| gnome-vfs-1.0.5-6


Version-Release number of selected component (if applicable):

gnome-vfs-1.0.5-6


How Reproducible:

100%


Steps to Reproduce:
1. umask 077
2. make sure that gnome-vfs is uninstalled completely
   (rm -rf /etc/vfs)
3. rpm -U gnome-vfs-1.0.5-6.i386.rpm
4. ls -l /etc/vfs
5. try to use the programs/scripts/libraries/data of the package as
   non-root user
6. rpm -e gnome-vfs-1.0.5-6

Actual Results:

* at 4:
  | drwx------    2 root     root         4096 Sep 13 16:33 /etc/vfs
* files can not be found/read at 5 and
* /etc/vfs still exists after 6.
Comment 1 Alexander Larsson 2003-02-25 10:04:54 EST
Its owned in at least gnome-vfs 1.0.5-13

Note You need to log in before you can comment on or make changes to this bug.