Bug 739469 - [vrit-manager]can't save default cache mode to new storage
Summary: [vrit-manager]can't save default cache mode to new storage
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 07:43 UTC by zhe peng
Modified: 2011-09-22 15:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-22 15:16:22 UTC


Attachments (Terms of Use)

Description zhe peng 2011-09-19 07:43:57 UTC
Description of problem:
create new storage with cache mode default not saved to guest.

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-6.el6
libvirt-0.9.4-11.el6
python-virtinst-0.600.0-3.el6
qemu-kvm-0.12.1.2-2.190.el6

How reproducible:
always

Steps to Reproduce:
1.Shut down a vm then open Virtual Machine Details window.
2.Click Add Hardware button
3.select Storage in left panel.
4.check "Select managed or other existing"
5.Browser an existing file 
6.select Floppy disk as Device type.
7.Change Cache mode to default.
8.Click "Finish" button.
9.check Floppy 1  performance options 
  
Actual results:
Cache mode change to none automatically.

Expected results:
Cache mode should same with step 7 setting.

Additional info:
this issue both occur on add IDE Disk,Virtio Disk,IDE CDROM storage

Comment 2 Cole Robinson 2011-09-22 15:16:22 UTC
Thanks for the report, but for RHEL, 'none' is the default, so this is correct behavior. We have to hardcode this default in virtinst since qemu devs did not want to set it at the emulator level.

Closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.