Bug 739473 - System hangs or kernel panic if safely remove USB HDD from GNOME
Summary: System hangs or kernel panic if safely remove USB HDD from GNOME
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 07:56 UTC by Viktor
Modified: 2012-02-27 23:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-27 23:43:22 UTC


Attachments (Terms of Use)
Kernel panic trace (3.06 MB, image/jpeg)
2011-09-20 17:36 UTC, Viktor
no flags Details
Fix this issue for Fedora 14 (2.11 KB, patch)
2011-09-27 17:29 UTC, Viktor
no flags Details | Diff

Description Viktor 2011-09-19 07:56:21 UTC
Description of problem:

This trouble a get on Fedora 14 i686/x86_64 (GNOME) and Fedora 15 x86_64 (GNOME). If connect USB HDD (I'm using  Samsung HX-M101TAB/G 1TB "2.5" USB 3.0) to my computer the system find it success, copy data to HDD or read data from HDD success. But if I safely remove HDD from my computer the system is freezing (Fedora 14) or kernel panic (Fedora 15). Also I get this bug with 3Q USB HDD. On Seagate USB this NO reproduce.


Steps to Reproduce:
1. Connect USB HDD Samsung or 3Q to computer.
2. Copy or read data from HDD.
3. In GNOME right click mouse on HDD and select Safely remove from menu.
4. Your get freez or kernel panic.
  
Additional info:
This bug reproduce not only for me, see https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/844957

Comment 1 Dave Jones 2011-09-19 19:59:50 UTC
what kernel version ?

this should be fixed in the 2.6.40 updates.

Comment 2 Viktor 2011-09-20 04:41:58 UTC
(In reply to comment #1)
> what kernel version ?
> 
> this should be fixed in the 2.6.40 updates.

On Fedora 15 I'm having x86_64 2.6.40.4 (last update 18.09.2011)
On Fedora 14 I'm having i686/x86_64 2.6.35.14.

The 3Q USB HDD hangs Fedora 14 (Fedora 15 not tested), Samsung USB HDD HX-M101TAB causes kernel panic on Fedora 15 x86_64 and Fedora 14 (i686/x86_64) (all system with GNOME).

If I umount HDD use  following command (from root):
"umount /dev/sdb"
that umount success (no hangs and no kernel panic).

P.S. I am sorry for my ugly english.

Comment 3 Dave Jones 2011-09-20 16:31:54 UTC
hmm. we really need to know more about that panic.
if you could capture the trace somehow (even if it's a photo) that would be great.

Comment 4 Dave Jones 2011-09-20 16:32:41 UTC
also, what filesystem is on the external drive ?

Comment 5 Viktor 2011-09-20 17:36:31 UTC
Created attachment 524074 [details]
Kernel panic trace

Kernel panic trace

Comment 6 Viktor 2011-09-20 17:37:12 UTC
(In reply to comment #4)
> also, what filesystem is on the external drive ?
I use NTFS file system (for more compability).
Today I'm exchanging Samsung HDD on Seagte USB 3.0 HDD (FreeAgent GoFlex 1TB).
But on Segate with USB 3.0 this bug reproduce. I think the problem lies in the USB 3.0 controller HDD.

Comment 7 Chuck Ebbert 2011-09-21 13:29:20 UTC
There is still fallout from that mess, and newly proposed patches to fix it:

https://lkml.org/lkml/2011/9/20/31
https://lkml.org/lkml/2011/9/18/124

Comment 8 Viktor 2011-09-27 17:29:23 UTC
Created attachment 525179 [details]
Fix this issue for Fedora 14

Hi, in attach I include modification patch from (https://lkml.org/lkml/2011/9/20/31) for Fedora 14 and 2.6.35.14. This patch helped me. The Fedora 14 no hangs after safely remove USB HDD. I hope this patch will be include to Fedora 14 update.

Comment 9 Josh Boyer 2011-10-04 14:42:17 UTC
Could you please try this update and see if the problems recreate:

https://admin.fedoraproject.org/updates/kernel-2.6.40.6-0.fc15

We've added another possible fix for this issue from upstream.

Comment 10 Josh Boyer 2012-02-27 23:43:22 UTC
No update in almost 5 months.

We've had even more fixes in this area since then.  If you can recreate this with 2.6.42.7 or newer, please open a new bug with relevant details.


Note You need to log in before you can comment on or make changes to this bug.