Bug 739476 - makedumpfile: The kernel version is not supported.
Summary: makedumpfile: The kernel version is not supported.
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kexec-tools
Version: 14
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Américo Wang
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-19 08:05 UTC by Jan Kratochvil
Modified: 2012-02-10 08:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-10 08:48:08 UTC


Attachments (Terms of Use)

Description Jan Kratochvil 2011-09-19 08:05:21 UTC
Description of problem:
It gives warning, it is probably false as makedumpfile seems to work OK.

Version-Release number of selected component (if applicable):
kexec-tools-2.0.0-41.fc14
kexec-tools-2.0.2-29.fc17

How reproducible:
Always.

Steps to Reproduce:
makedumpfile -c kernel-2.6.35.14-95.fc14.x86_64.vmcore foo

Actual results:
The kernel version is not supported.
The created dumpfile may be incomplete.
Copying data                       : [100 %] 
The dumpfile is saved to kernel-2.6.35.14-95.fc14.x86_64.vmcore.dumpfile-c.
makedumpfile Completed.

Expected results:
Copying data                       : [100 %] 
The dumpfile is saved to kernel-2.6.35.14-95.fc14.x86_64.vmcore.dumpfile-c.
makedumpfile Completed.

Additional info:
./makedumpfile-1.3.5/makedumpfile.h:452:
#define LATEST_VERSION		KERNEL_VERSION(2, 6, 32)/* linux-2.6.32 */

Comment 1 Américo Wang 2012-02-10 08:48:08 UTC
Upstream has the same problem, so we need to wait for upstream, and then push the fix into Fedora 17, unlikely in Fedora 14.


Note You need to log in before you can comment on or make changes to this bug.